After upgrading to Mountain Lion, I have experienced some weird problems with network share permissions. This network share is a Windows server which I login to like so: smb://DOMAIN;USERNAME@networkshare.address/folder

What I see

Permissions error in TextEdit when saving on network share

What I cannot do

  • Create a new file and save directly to the share.
  • Open an existing file and save my changes.

What I can do

  • Create new folder
  • Delete folders and files
  • Rename folders and file
  • Move folders and files
  • Drag and drop from my desktop to the share drive

Apps that ignore the "problem"

With these programs, I am able to save new file into the share drive and overwrite changes to an existing file.

  • Adobe CS6: Photoshop, Illustrator, Dreamweaver, etc
  • Microsoft Office: Word, Excel, etc

Apps that display the permissions error message

With most (all?) Mac apps, the permissions error presents itself in some form or fashion.

  • TextEdit, Preview
  • Pages, Numbers, Keynote
  • Coda 2

Coda 2 is unique in that it will let me "Replace" the file, but clicking "Save" will not work.

Permissions error in Coda 2 when saving on network share

What else have I tried?

  • I have Repaired the Home Directory and Permissions and ACLs
  • My IT department has confirmed I have all read/write access to the share drive and has even gone so far as to reapply the permissions to every single folder and file
  • I have connected via cifs and by using the IP address of the server
  • I have joined the domain via the Users and Groups pref pane (all this does is not ask for your network login anymore when connecting to the share)
  • I have confirmed with other coworkers this affects them as well (some with Lion, some with Mountain Lion)
  • I have checked the "Ask to keep changes when closing documents" option in the General pref pane

As you can see, this is weird. My IT department suggested I wipe my computer. I don't see how that would have any affect and is really a last resort. I'm hoping someone here can shed light on this before I move forward with that. Wiping the machine and reinstalling the OS doesn't help. Word is that it has something to do with ACLs.

  • This is not an answer to your question, but I have a very similar (but somewhat different) issue copying files to a Lion 10.7 share. If I get any responses, they may be helpful to you. See apple.stackexchange.com/questions/87076/…. – Michael Mar 28 '13 at 16:17
  • 1
    This is a classic POSIX/ACL conflict from my experience. Is it a Mac Server? I'm guessing ACLs haven't been set from server side properly. Wiping your Mac will not fix it. When ACLs are not set on a file share individual files will maintain their own unique permissions based on which group member created the file. I had several issues like this with my first Mac Server I setup and applying ACLs fixed it. If you can provide more info on how the server is configured I may be able to provide more detail, but suffice it to say your Mac is not the problem here. – bispymusic Mar 28 '13 at 18:51

You must log in to answer this question.

Browse other questions tagged .