5

My Library appears to be intact. All the events and albums are normal in thumbnail view but when I open a picture I get this exclamation point error icon that fills the screen.

Looks fine in thumbnail mode, exclamation point alert but I get this error icon when I try to open the picture. problem

Haven't ever seen it before. I recently upgraded to iPhoto '11 (9.3.2) and Mountain Lion and switched out my Macbook hard drive. I imported my iPhoto Library from my old drive using Apple's Migration Assistant.

I realize that I have a lot of variables. I have tried many fixes: starting up iPhoto holding down Option and Command, trying all of the repair options, checked the permissions on the photos, rebuilt the Library and none of them have worked.

What else should I do and or try?

1
  • Tried to post as pictures but have to have 10 rep, so put in links. Sorry. Sep 13, 2012 at 20:06

4 Answers 4

2

The ! turns up when iPhoto loses the connection between the thumbnail in the iPhoto Window and the file it represents.

Surefire fix: Restore from backup. Otherwise...

Option 1

Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Repair Database. If that doesn't help, then try again, this time using Rebuild Database.  

If that fails:   Option 2

Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)

This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.

Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one.   

0

Turns out the iPhoto Library was corrupted when I upgraded to the new iPhoto.

After trying some of terrydev's suggestions iPhoto suddenly said it needed to upgrade the database to work with the new version. After a lot of spinner time it just nuked the Library. The pictures were all still there, but any meta data attached (faces, albums) was gone.

I went back to the old Library (essentially my backup) and copied it over. Only lost about a week of data.

0

Go to iCloud, then to Photos, click on it and you will see Optimise iPhone storage or download and keep originals; tick the download and keep originals option and backup your phone again. It will go back to clear photos without the i symbol.

0

I had this same problem.

I fixed it by turning off 'icloud photo library' in settings > photos and cameras, and then selecting 'remove from iphone'.

After a while, all the photos were removed from my phone (they're still in icloud).

Then i turned 'icloud photo library' back on (i had ‘optimize iphone storage’ on).

I woke up the next day and found all my photos back on my phone, with no exclamation mark, and i was able to load the picture when i needed to open/edit/post/send it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .