When opening an application installed from the App Store (TextWrangler) I am prompted to sign in. After entering the correct Apple ID and password I get an error, An unknown error has occurred. This only happens with one app, other apps installed are OK.

This error also occurs when I sign in to the App Store. So its not just affecting a single application.

This also seems to be affecting my iCloud login. It prompts for a password then just seems to hang.

I spoke with Apple Support yesterday. They had me delete all Caches from /Libary/Caches, ~/Library/Caches, and a few cookies then restart my iMac. This fixed the issue yesterday. Today I start my Mac and get the same error again. I called Apple Support and got the runaround, I was told to use ExpressLane which doesn't really seem to have a solution.

How can I permanently fix this error?

Previous attempt to identify/triage the error

Searching online turns up similar suggestions to clear caches and cookies, but also some more extreme suggestions involving network settings that I am hesitant to try.

Logs after starting TextWrangler and being prompted to login:

9/19/12 10:01:30.611 AM com.apple.backupd[889]: Couldn't find en0.
9/19/12 10:01:30.638 AM com.apple.backupd[889]: Backup completed successfully.
9/19/12 10:01:58.592 AM RockMelt[306]: Cannot find function pointer CMPluginInFactory for factory 3487BB5A-3E66-11D5-A64E-003065B300BC in CFBundle/CFPlugIn 0x796aa090 </Users/jon/Library/Contextual Menu Items/Google Notifier Quick Add CM Plugin.plugin> (not loaded)
9/19/12 10:01:59.885 AM RockMelt Helper[931]: Internals of CFAllocator not known; out-of-memory failures via CFAllocator will not result in termination. http://crbug.com/45650
9/19/12 10:02:00.615 AM RockMelt Helper[931]: CGSLookupServerRootPort: Failed to look up the port for "com.apple.windowserver.active" (1100)
9/19/12 10:02:07.797 AM WindowServer[89]: CGXDisableUpdate: UI updates were forcibly disabled by application "RockMelt" for over 1.00 seconds. Server has re-enabled them.
9/19/12 10:02:11.035 AM WindowServer[89]: reenable_update_for_connection: UI updates were finally reenabled by application "RockMelt" after 4.24 seconds (server forcibly re-enabled them after 1.00 seconds)
9/19/12 10:02:34.240 AM Blink Lite[310]:REDACTED
9/19/12 10:03:07.693 AM com.apple.launchd.peruser.501[192]: ([0x0-0xae0ae].com.barebones.textwrangler[938]) Exited with code: 173
9/19/12 10:03:39.054 AM librariand[951]: MMe quota status changed: under quota
9/19/12 10:03:40.741 AM com.apple.security.pboxd[959]: Bug: 12B19: liblaunch.dylib + 23849 [224CB010-6CF8-3FC2-885C-6F80330321EB]: 0x25
9/19/12 10:04:00.293 AM Dock[205]: LaunchPad: __53-[LPAppManager(StoreSupport) _acceptStoreConnection:]_block_invoke_0 app store xpc message error: Connection invalid
9/19/12 10:06:11.123 AM TextEdit[949]: SCNetworkReachability server not available
9/19/12 10:06:11.124 AM TextEdit[949]: SCNetworkReachability server not available
9/19/12 10:06:11.130 AM TextEdit[949]: socket(PF_ROUTE) failed: Operation not permitted
9/19/12 10:06:11.000 AM kernel[0]: Sandbox: sandboxd(990) deny mach-lookup com.apple.coresymbolicationd
9/19/12 10:06:12.423 AM sandboxd[990]: ([949]) TextEdit(949) deny mach-lookup com.apple.SystemConfiguration.SCNetworkReachability
9/19/12 10:06:12.426 AM sandboxd[990]: ([949]) TextEdit(949) deny system-socket
9/19/12 10:08:22.725 AM com.apple.launchd.peruser.501[192]: ([0x0-0xbd0bd].com.barebones.textwrangler[1015]) Exited with code: 173
9/19/12 10:09:00.951 AM Dock[205]: LaunchPad: __53-[LPAppManager(StoreSupport) _acceptStoreConnection:]_block_invoke_0 app store xpc message error: Connection invalid
  • Have you tried uninstalling TextWrangler by removing it from Launchpad or removing other files related to it?
    – Lri
    Sep 13, 2012 at 18:23
  • @Lri Yes I have. That actually exacerbated the problem yesterday. After removing it I could not sign in to the App Store to reinstall it.
    – Freiheit
    Sep 13, 2012 at 18:36
  • Does mdfind -name textwrangler still show some files? Removing an application from Launchpad runs uninstalld which might affect the way App Store sees the application.
    – Lri
    Sep 13, 2012 at 18:52
  • Edited, "This error also occurs when I sign in to the App Store. So its not just affecting a single application."
    – Freiheit
    Sep 13, 2012 at 18:59
  • Check what the error logs say. Applications > Utilities > Console.
    – duci9y
    Sep 17, 2012 at 16:24

4 Answers 4


I found a solution. Another forum post describing similar issues suggested deleting /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist. I backed that file up, deleted it, and restarted. I can now log in and out of AppStore, access all of my AppStore purchased apps, and it 'sticks' across shutdowns and restarts.

Process is pretty simple, I'll spell it out for future reference:

  1. Open Terminal
  2. cd /Library/Preferences/SystemConfiguration
  3. cp NetworkInterfaces.plist ~/NetworkInterfaces.plist.bak - Make a hasty backup in your home directory
  4. sudo rm NetworkInterfaces.plist delete the original
  5. Restart your Mac
  6. Open AppStore and try to sign in. It should work.

Apparently this works because the MAC address is used as part of the receipt/authorization process.

  • Out of curiosity, where is NetworkPreferences.plist?
    – Ethan Lee
    Sep 23, 2012 at 21:00
  • @ethanlee16 - Edited my answer, its in /Library/Preferences/SystemConfiguration.
    – Freiheit
    Sep 24, 2012 at 13:35
  • This didn't work for me, unfortunately. Dec 28, 2012 at 19:56
  • @AlexKaushovik - Were you experiencing the same problem my original question posed?
    – Freiheit
    Jan 2, 2013 at 15:08
  • This did work for me. May 6, 2014 at 18:14

What worked for me was to go to Store>Sign Out

Once I was signed out, I was able to sign back in and purchase/install apps correctly. Not sure why this happened, but it fixed it for me.


As an Apple/Mac repair person, I was baffled by the "An error has occurred couldn't communicate with helper app" dialog when trying to use the App store to do a software app. I read through these thread and tried deleting App Store and Network prefs with no success. Also reinstalled OS with no luck.

Here's what worked: Do a Safe Boot (hold shift key while booting), then go to App store and try downloading/installing updates. It worked and the problem disappeared when the Mac rebooted.


Same thing happened to me, and this was how I have fixed it: http://yasar.senturk.name.tr/blog/2012/09/26/hackintosh-app-store-an-unknown-error-has-occurred-fix/

1- Edit /Extra/org.chameleon.Boot.plist and add following lines:


2- Go to System Preferences, and then Network. Remove all network adapters.

3- Delete /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist and reboot computer.

4- Go to System Preferences, and then Network. Click on + button, select “Ethernet” from “Interface” combo box, then click OK.

5- Reboot computer.

6- Go to System Preferences, and then Network. Click on + button, select “WiFi” from “Interface” combo box, then click OK.

  • 1
    How does this answer differ from the accepted one (besides the first step which is specific to Hackintosh'ed models)?
    – nohillside
    Feb 4, 2013 at 5:07
  • Because the accepted answer is working only for some Hackintosh models while this one is working for others. Since original question doesn't indicate that if it was a Hackintosh or not, I wanted to write the solution worked for me. Feb 4, 2013 at 17:34
  • The fact that the asker called Apple Support seems to indicate that Hackintoshes are not involved here at all...
    – nohillside
    Feb 4, 2013 at 17:46
  • You are right. I didn't notice. My bad. Feb 4, 2013 at 20:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .