0

I have been using Virtual DJ on my machine. The setup is where I want audio to play over the headphones and use a USB sound card to play audio into my headphones so I can listen to music before I play it for everybody.

enter image description here

However, the last time I tried, I got an error message saying "Error in the sound driver of Core Audio. Your sound card is probably not connected, or the settings are incorrect".

enter image description here

If I use the headphone by themselves, the USB sound card by itself, or my speakers by themselves, they all work individually.

How do I go about figuring out what's wrong here?

  • Just asking did you tried rebooting or killing the CoreAudio Drive ? – Matthieu Riegler Sep 13 '12 at 12:54
  • I have rebooted several times. I do not know how to kill or reinstall the Core Audio driver. – Raj More Sep 13 '12 at 14:28
  • You can kill it with killall /usr/sbin/coreaudiod in the terminal but rebooting almost does the same thing so it won't help you. – Matthieu Riegler Sep 13 '12 at 19:51
  • I tried killall. The response is No matching processes belonging to you were found. Is it that the service somehow is AWOL? – Raj More Sep 14 '12 at 1:03
  • try ps -e | grep core If you don't see coreaudiod it means it's not running. That could a hint to your problem. – Matthieu Riegler Sep 14 '12 at 1:07
1

When the USB sound card is plugged to the Mac, do you see it in System Profiler (from Apple Menu -> About this Mac -> More Info... -> System Report) as a USB device ?

If so, can you then see the audio device in System Preferences -> Sound -> Output ? If not, would other USB devices work on the same USB port ?

  • I see it in the system profiler. I cannot see it under System Preferences. It is because the driver went bad? – Raj More Sep 13 '12 at 19:15
  • CoreAudio is part of the OS, have you installed extra drivers ? – PEM8000 Sep 14 '12 at 12:49
  • I guess the best way I can answer that is to say I have installed more software than comes in on the Mac out of the box. I do not know if the software I have installed has installed any drivers. How do I check that? – Raj More Sep 14 '12 at 14:48
0

I figured it out!

Under Utilities, there is a MIDI setup. This had stored a profile for my Virtual DJ pro software.

I deleted that profile, restarted my software, and the error went away.

Apparently, there was an invalid configuration saved that was causing the issue. I wish I had saved screenshots of the profile so that we can actually see what the error was.

0

i figured out how to end this problem. I closed VDJ, then opened application/utilities/audio midi setup. then delete the VDJ advanced setup. then re-open VDJ and it worked like a charm again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .