I have now tried opening the iMac and removing the cables to the SSD, it still gets stuck on the white screen. I tried again, removing the cables to the HDD as well and the same thing occurs.

No idea what to do from here.

I've done quite a bit of troubleshooting and this problem sounds like mine except that I have an iMac, not a MacBook.

While using Windows 7 (via Bootcamp) I shutdown my 27 inch 2011 iMac. After it was shutdown I pressed the power button to turn it back on, it proceeded to play the startup sound and then froze on a white screen. There is no cursor or anything else on the screen.

I tried unplugging all cables, including the power, reconnecting only the power and attempting to turn it back on with the same result.

It does not respond to any key combinations. Holding Alt while it boots does not bring up the disk selector. Holding T does not put it into Target Disk mode. Holding Cmd-Opt-R-P does not have any affect. Holding Shift does not put it into safe mode. Holding Cmd-V does not bring up verbose boot.

I made a copy of the OS X Recovery Disk onto a USB but am unable to use it as the Mac won't boot from it (and won't bring up disk selector to select it).

It was working fine minutes before I shut it down and then suddenly refuses to boot and I am at a loss as to what to do. Sadly, there are no Apple Stores or Genius Bars in my country, so feel free to point to any and all self-help resources I might use.

  • 1
    Did you try command-s? Sep 13, 2012 at 14:39
  • @theAmateurProgrammer I have now, no affect. I don't think it's picking up any of the boot key combos.
    – carbin
    Sep 13, 2012 at 19:58
  • 1
    are you using a bluetooth keyboard to send these boot options? i've run into problems when doing this, and using a usb keyboard is more reliable when booting up
    – Ethan Lee
    Sep 15, 2012 at 5:42
  • @ethanlee16 Tried two different wired keyboards and one bluetooth keyboard. Two of the three keyboards I have successfully used before to bring up the boot selector and enter Target Disk Mode and now neither will do it.
    – carbin
    Sep 15, 2012 at 7:22
  • 2
    Sounds like your EFI is corrupted. Apple usually replaces the logic board for that. If you could tell us where you live, we can probably find a Mac Repair Shop for you.
    – duci9y
    Oct 6, 2012 at 12:40

4 Answers 4


Here is what you know from your excellent details:

  1. The keyboard isn't working since all of the shortcuts get handled from the firmware in the Mac.
  2. The Mac can't find any bootable OS X due to corruption or hardware failure

Why the keyboard isn't working isn't yet clear. I would disconnect everything including the power and then remove both RAM sticks - noting which was on the top and which was on the bottom.

Next, plug the Mac in and power it up with nothing connected. You should get three beeps indicating the POST (power on self test) detected no RAM. If you have severe hardware problems, it won't know the RAM is missing and you'll know you need to get inside to fix it.

Assuming this works, power it off after waiting to see if it boots in 5 minutes time (really wait that long for the Apple logo to show up). While you are waiting listen carefully for rhythmic noised from the hard drive. It shouldn't keep seeking past the first 45 seconds and if so - you will know the controller or the drive is faulty. It should spin quietly after a few minutes or be reading the drive if it's corrupt and the hardware / OS is trying to fix things.

Next - power it off by the button and put the "top" piece of RAM in the "bottom" slot and repeat. Lastly - if you get to the white screen at this point, try another keyboard (command-s or shift held down are the best options here for troubleshooting) to see if you can isolate the failure further.

I tried to make some assumptions about what is wrong and you can edit the question or ask another with the step that fails referring to this question if you want to isolate things further before attempting a repair.

  • Already tried removing RAM. It beeps (and stays on a black screen) with no RAM inserted. And tried each stick in isolation. I've tried three different keyboards, 2 USB and 1 bluetooth. 1 of the USBs and the bluetooth I have successfully used before to bring up the Boot Selector, and that USB was working fine minutes before this problem started (and was able to bring up the boot selector about an hour before this happened). At this point I'm fairly certain the problem is what I directed to in my edit).
    – carbin
    Sep 18, 2012 at 20:55
  • Also, I left it running for around 2-3 hours while I worked a couple days ago to see if it would eventually boot but it stayed on the white screen. And the main drive is an SSD so it won't make any noise (I probably should have mentioned that in my post).
    – carbin
    Sep 18, 2012 at 20:58
  • Sounds like the hard drive has failed and you'll need to pull it. I've seen plenty of HDD fail and lock the SATA bus / boot process like this (preventing booting from another source like optical or USB/FW). Great details and best of luck. Once you've disconnected the SATA to MLB cable you should be able to boot from an external drive and verify everything else is fine. Also - before pronouncing the drive dead, reseat the cables to ensure it's just not a bad connection (unlikely, but painful to replace a drive when a cable was simply loose).
    – bmike
    Sep 18, 2012 at 21:01
  • I have now had it opened and removed the cables to the SSD and the HDD and vice versa. Tried putting in a USB drive with Recovery Assistant installed on it, and nada, nothing works. Does the same thing, getting stuck at the white screen.
    – carbin
    Sep 29, 2012 at 5:48

Along with the link you mentioned in your edit, this is also your exact problem. Go down to the OP's solution to find that he opened up his iMac to fix this. If you've configured your startup disk as Macintosh HD, the only way to boot to your USB key would be to remove the connection to the hard drive by opening up your iMac. You might want to ask a repair shop to do this for you, or send it in to Apple somehow. If you decide to do this yourself, here's the iFixit guide. Good luck!

  • I am almost certain that is what the issue is. I have designated Macintosh HD as the bootdisk to stop it booting into Bootcamp by default so it makes sense. I've ordered 2 suction cups and a Torx T10 to fix it so I'll have to see what I can do once they arrive.
    – carbin
    Sep 16, 2012 at 23:21

You should try and hold down alt on boot, then select which hard drive you will be booting from it is possible there is none configured for startup.

Then once it has booted set your default hard disk in startup disk under system preferences.


I ran into the same problem, iMAC would not boot past the white screen, and I had lost my recovery disks. so I went to Apple website and bought more recovery disks, and when it booted up into recovery mode, it was not showing a target disk to install the op system because it was corrupt, so I then opened up the disk utility and erased the hard drive and then went back to the installer and it then showed the boot target. so I then continued to re-install the op system! Note: it will only bring up the installer and disk utility with the recovery disks. Good To Go

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .