I lost my password to my Time Machine backup. It's on a Seagate FreeAgent USB drive. I don't mind losing the data, I just can't figure out how to format the drive. I found this thread, however, the "Erase" tab that's mentioned doesn't appear when I select the drive. It's also grayed out for the partition.

I've tried running VirtualBox and accessing the drive in Windows, but the FreeAgent drive is grayed out as one of the available devices.

I've also tried hooking up the disc to a Windows XP machine and running the EaseUS partition tool, but that tool doesn't give me the option to format (as if it was grayed out).

Any thoughts or ideas?


you've probably answered this already, but you need to use the terminal.

diskutil list

and then

diskutil eraseDisk nameofnewdisk /dev/diskX

replace diskX with disk0 or disk1 or whatever from diskutil list

| improve this answer | |

Sort of surprized you can't format via Disk Utility app.

Check the Seagate web site and see if they have a disk utility app for the Mac. I'm guessing they have something that will format the disk. IIRC my Freeagent GoPro drive had some utlities on the disk (of course I wiped them out, and reformatted the drive). Worth a check.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .