My MacBook started to get really slow recently. Now it can’t start up properly anymore. All I see is the Apple logo and then it shuts down. I've tried rebooting multiple times, but I've seen the same result over and over again.

So, I tried to reinstall my OS, but for some reason I get the error I cannot unmount my disk. And the partition seems to be locked, so I can't reinstall the OS over the internet.

Do I have a damaged disk?

2 Answers 2


You cannot unmount the disk you're working on, obviously.
Try to boot from a different media type other then your HD (USB-drive, DVD,...) and then try again.

(Mountain) Lion allows you to create a bootable USB-drive or DVD. If you do so, you'll be able to unmount (and format) your internal Macintosh HD.

  • He said that he couldn't boot, and was trying to reinstall the OS, so I'd say that he was unable to unmount the drive when booted from a DVD.
    – daviewales
    Dec 3, 2012 at 10:12

I had this problem, and I resolved it by completely reformatting the drive. You will need to back up your computer first. To back up your computer, start your Mac in target disk mode (hold down Command-T on boot) then connect it to another Mac using Firewire. The broken Mac should appear as an external Hard drive on the second Mac, and you will be able to copy files from it to an external drive. You can then try using Disk Utility, or possibly a command line utility to reformat the drive. (If Disk Utility still can't unmount the drive, I would recommend using a command line utility, as they are usually more powerful, and can cope with problems that Disk Utility can't cope with. Google how to format a drive using command line on a Mac)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .