I use Remote Desktop Connection on my 10.6.2 to connect to Windows XP and Windows7. I can share clipboard between mac and Windows XP but Windows7.

Any idea how to make it work for Windows 7?

It seems to me that it work sometimes. Not sure when and why.

6 Answers 6


You should try to make sure the process rdpclip.exe is running in your Windows 7 box.
If it is, try killing it and restarting it.

This process transfers the clipboard contents over RDP.

  • 1
    I restart the box basically every day. Strange thing is that sometimes copying things over RDP works, sometimes not.
    – Radek
    Sep 26, 2012 at 22:37
  • 2
    I didn't have to restart it after killing the process, it just restarted by itself after reconnecting to the RDP.
    – arturomp
    Jan 29, 2014 at 18:51
  • 5
    Killing rdpclip.exe and re-running it worked for me!
    – Levani
    Feb 6, 2015 at 12:14
  • 1
    I was using Remmina to RDP from linux to a windows machine and the shared clipboard was not working. Killing rdpclip.exe and re-running it worked for me so it appears this is not specific to windows 7/10 but also applies to Windows Server.
    – Frito
    Mar 11, 2019 at 12:12
  • 1
    I faced this in Mac OS to remote Windows 10. After killing rdpclip.exe and re-running it worked for me.
    – Kuppuraj
    Jul 31 at 8:12

Batch this, and use it in a CMD file, Make a program Group / Desktop link to the batch for Citrix PS users, or even better, use VBS to do the task and Link it to the Desktop:

%SystemRoot%\system32\Taskkill.exe /im rdpclip.exe /f /t



Something I found on the Windows forums is to enable all of the drives as local resources (check the box labeled "Drives") when you connect to the remote machine. This allows me to copy and paste now.


Open task manager on the remote desktop . In the Process tab , you will find process rdpclip.exe . Right click and select "end process" . Search for executable rdpclip.exe in your system and run it . This solved the copy/paste problem for me .


I had the same problem in my Mac and as I noticed in RDP connected windows os appeared "attached drive" in section "Devices and drives". So that was the only thing for me to copy files from OSX to WIN through RDP client.

You have to edit desired connection and under the tab redirection you have to specify folder to redirect. soon after you start modified remote connection you will see new folder under the device and drivers in This PC


Be sure to use CTRL + V to paste in Windows, not + V.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .