13

Since I upgraded to Mountain Lion from Lion I see the CalendarAgent process occupying a large amount of 1 CPU on my late-2008 MacBook Pro. To fix this (as suggested by a Google result) I tried removing all online calendar accounts then re-adding them. This seemed to work for a while, but now the problem has returned (perhaps due to me either deleting some iCloud calendars or adding an additional Google calendar delegate). I don't really want to have to remove all my calendar accounts each time I add or remove a single calendar, so can anyone point me to the root cause of the problem?

In case it's useful, the call graph from the process is pasted here.

UPDATE: I removed one of the delegates from one of my Google calendar accounts, and that prevented this problem occurring. This isn't really a solution though, as I now can't access that calendar.

  • Are any of these calendars Microsoft Exchange calendars you have access to through Exchange webmail? If so, login to the Exchange account and dismiss any reminders. If you don't have access to the Exchange calendars, ask the owners to dismiss any reminders. – IconDaemon Dec 5 '12 at 19:12
  • You might want to read through this post for another solution: robert.accettura.com/blog/2012/08/19/… – IconDaemon Dec 5 '12 at 19:26
3

I am still looking for a solid answer.

In the meantime, I have the following script running in AppleScript Editor. This script looks for the CalendarAgent every 15 seconds and kills the process.

This renders calendar syncing unusable, but at least I can use my Mac again. I will let this run until I find a permanent solution.

The script is:

repeat
  set app_name to "Finder"
  do shell script "killall -9 CalendarAgent"
  delay 15
end repeat
  • Never really got to the bottom of this, though this was a solution to the symptoms, hence accepting. – Nick Hawes Apr 22 '13 at 9:42
9

May have to kill and rebuild Calendar db:

  1. Disable the Calendar service from your account in System Preferences → Internet Accounts

  2. Remove the preferences/database files for Calendar:

    rm -r ~/Library/Calendars/ ~/Library/Preferences/com.apple.iCal.plist
    
  3. Re-enable the service.

Source: http://robert.accettura.com/blog/2012/08/19/how-to-stop-calendaragent-from-eating-cpu/

  • 2
    Welcome to the site. We encourage people to summarize links but it's OK to just contribute links knowing that they sometimes get converted to comments or voted down as we try to get people to contribute to the body of knowledge here that's under a CC license. – bmike Dec 31 '13 at 15:54
  • 1
    Worked for me. Remember: when re-enabling it eats CPU for a little while. – joost May 16 '17 at 9:29
3

Using Google delegates definitely caused the high-CPU problem with me.

The simple solution is to:

  1. Uncheck the delegation w/in Calendar's Account info window (as indicated by the UPDATE above)
  2. Change your Google calendar sharing by selecting the desired calendar(s) within the Google Sync Settings page: https://www.google.com/calendar/syncselect

Making this change eliminated the high-CPU problem, without needing to resort to the kill-the-CalendarAgent approach.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .