I don't have Mac computer/laptop. I have only iPad. Now I am getting this error "Cannot connect to iTunes" although I have never used iTunes. So I cannot install or update any apps in iPad. How can I solve this problem?

Perhaps this is conspiracy but I got the error after I tried to install iTunes to Debian, more here, my laptop. My laptop and my iPad are connected to the same wireless Ethernet but they are not linked. Could this cause the malfunctioning of my iPad?

It is very irritating because this error happened totally unexpectedly.

  • When is that error showing? – Thecafremo Sep 11 '12 at 7:26
  • @Thecafremo the moment I try to install any app or update any app, after succesfully inserting password. – hhh Sep 11 '12 at 8:39
  • Try shutting down the Debian running iTunes and see if it helps. – Thorbjørn Ravn Andersen Sep 11 '12 at 12:31

Try this Wibbly-Wobbly solution:

  1. Open Settings and go to General / Date & Time.
  2. Tap Set Automatically to turn it off.
  3. Tap on Set Date & Time and enter a date a couple of years in the future.
  4. Go out of Settings, and back again, and turn on Set Automatically. This will restore the current date and time.
  • Are you sure you answered the right question? – nohillside Sep 11 '12 at 10:32
  • @patrix Pretty much ;) – Thecafremo Sep 11 '12 at 10:55
  • How do the time settings affect application installation? – nohillside Sep 11 '12 at 12:56
  • 1
    @patrix Not with installation, but with the connection to the AppsStore. Sounds weird, but apparently, it works. – Thecafremo Sep 11 '12 at 13:08
  • It worked! What-the-apple -- how could I have guessed that? Millions times thanks +1! – hhh Sep 11 '12 at 13:21

Thecafremo's suggestion did not work the next time I got this bug. I realized that it had to do something with the time, some sort of time-drift in my network, so I turned off the WIFI and connected to the internet through 3G -- and it worked!

Some sort of security -validation is based on the time and with heavily-network-reliable devices such as iPad, you seem to get this kind of odd bugs -- not really sure whether some other way exist to solve this, what about without 3G card?

  • ...I do hate this, I am unable to download over 50MBs' apps because of not being connected to the WIFI, no way around? – hhh Sep 30 '12 at 23:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .