I've been using the Kindle reader app on my iPhone and it was working as advertised for a while. However, yesterday for no apparent reason it has stopped being able to download books. I bought a book, went to my list of books in the Kindle app, and tapped the "download" control. The message reads "Downloading 0.0%" and just stays there. I tried downloading another recent purchase. Same deal. I tried restarting the Kindle app, and then the iPhone, but that didn't help. I tried going onto the Amazon and "sending" the books to my iPhone with no result. I made sure the iPhone is connected to my home wi-fi network.

Has anyone else seen this problem? Know of a solution?


2 Answers 2


You say it suddenly started working again?

My best guess is that it was caused by GoDaddy's DNS servers going down. This has caused generally odd behavior across the internet as many sites and URLs were 'forgotten' temporarily. Many sites became unreachable.

There's a chance the Kindle downloading mechanism relied on an address that was affected.


Restarted the iPhone again and now it's working.

No idea why it wasn't working before.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .