Similar question to this, but my other computer is a PC. (PC seeing external hard drive from the Mac over the Internet.)

My external is formatted exFAT. Neither the Mac nor the PC have issues using it. When I connect it to the PC, the Mac can read/write on the external HDD over the Internet. However, when I connect it to the Mac, the PC can identify it (through Network) but the access is denied. The message is

\192.168.xx.xx\HDD is not accessible. You might not have permission to use this network resource. The parameter is incorrect.

At the first time to try, it asked me to log in to the Mac, which worked, and has never shown up again. I can see the hard drive in question in the folder as "share", but double-clicking does not let me in, instead I get the above error message. One weird thing is the Property window for the hard drive (gotten from the right-click menu on the PC) shows it is NTFS, which is wrong.

I've also tried mapping the drive to a drive letter. I tried to map it from the PC by assigning Z: drive with \192.168.xx.xx\HDD, then Z: drive is shown as a network drive with right capacity size (XXX GB free of 931 GB). But again, when I click it, it fails to get in. "Z:\ is not accessible, The parameter is incorrect."

I have no problem accessing the Mac's user directory from the PC, so I also tried to map the drive to a folder in the user directory of the Mac (\Users\myuserID\) by running ln -s \Volumes\HDD HDD on the command line, but this trick doesn't work for me.

I don't think Sharepoint is necessary, since my Mac is on Mountain Lion. The PC is running Windows 7.

So, now, I don't know what to do. Any suggestion?

  • Reposted question to Super User: superuser.com/questions/495251 – cmikeb1 Oct 29 '12 at 7:26
  • 2
    You should use your Mac credentials to connect to the Mac, otherwise you do it as an anonymous user which usually are denied access. – Thorbjørn Ravn Andersen Dec 25 '12 at 19:05
  • @Joonsuk Kim By 'Access over the internet' Do you mean, outside of your network? Because if so "192.168.xx.xx" will not work outside of your network. – Phorce Jan 27 '13 at 13:35
  • Just to verify, have you added the external volume as a "Shared Folder" within File Sharing pane of System Preferences? – bispymusic Mar 4 '13 at 21:54

You may get better help on the Windows side of this problem from Super User.

As for the Mac side, mounting the drive in a folder in your user directory should work and is a good idea. However, you used the wrong command. ln -s makes a symbolic link, like a Shortcut on Windows or an Alias on the Mac. You can mount the drive temporarily using the diskutil mount command. There is a way to do it permanently, but I don't know how to do it offhand; you should ask a new question about that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .