My time machine is backup is very slow. Connection is FireWire 800. Transfer is around 5 Mb/s or 0.5 MB/s, which seems slow. I've seen plenty of mention online of very slow Time Machine backups. What are some techniques or suggestions to speed this up?

I have:

  • Run the Disk Utility Repair tool. Everything is fine.
  • Disabled Spotlight on the remote disk

Searching for backupd in system.log gives the following:

13:29:33 Starting standard backup
13:29:33 Backing up to: /Volumes/BACKUP_DISK/Backups.backupdb
13:29:36 Event store UUIDs don't match for volume: Macintosh HD
13:29:36 Waiting for index to be ready (101)
13:29:55 Node requires deep traversal:/ reason:must scan subdirs|new event db|
13:42:53 No pre-backup thinning needed: 39.84 GB requested (including padding), 71.68 GB available
13:42:53 Waiting for index to be ready (100)
14:23:37 Bulk setting Spotlight attributes failed.
14:29:39 Copied 2.0 GB of 28.7 GB, 69560 of 113624 items
15:29:57 Copied 2.8 GB of 28.7 GB, 69560 of 113624 items
16:30:00 Copied 3.3 GB of 28.7 GB, 69560 of 113624 items
17:30:04 Copied 3.8 GB of 28.7 GB, 69560 of 113624 items
18:30:07 Copied 4.3 GB of 28.7 GB, 69560 of 113624 items
18:51:23 Bulk setting Spotlight attributes failed.
19:30:07 Copied 4.8 GB of 28.7 GB, 69999 of 113624 items
20:30:19 Copied 5.4 GB of 28.7 GB, 69999 of 113624 items
21:30:28 Copied 6.2 GB of 28.7 GB, 69999 of 113624 items
21:38:36 Stopping backupd to allow ejection of backup destination disk!
  • 6
    What is the speed of copying a resonably large file to the disk TM is on? This is to see if TM or the disk is the issue
    – mmmmmm
    Jan 14, 2011 at 0:31
  • Transfer rates to the disk are 500 Mb/s == 50 MB/s. Normal FW800 speeds.
    – user588
    Jan 15, 2011 at 3:10
  • Make sure the firmware is bang up to date. Mine wasn't and was slow, but got faster since then.
    – Alex
    Jan 18, 2011 at 23:26
  • What firmware? OS X System Software? OS X EFI updater? I keep up-to-date however Software Updater tells me to, so AFAIK this isn't the issue.
    – user588
    Jan 18, 2011 at 23:42

7 Answers 7


On El Capitan to High Sierra OS - the io is throttled in some cases. You can review these steps in case they apply in your case. Not everyone sees this speed up, but it shouldn’t be hard to test and reverse if it doesn’t help you. Anyone on Mojave and newer should look to other fixes like testing a backup to a blank or erased drive.

Time Machine ridiculously slow after El Capitan upgrade

The throttle should be evident in observing the backupd usage of the filesystem:

sudo fs_usage backupd

Writing a command to /etc/sysctl.conf and then restarting should disable that throttle:

echo 'debug.lowpri_throttle_enabled=0' | sudo tee -a /etc/sysctl.conf

Or without restarting:

sudo sysctl debug.lowpri_throttle_enabled=0

You'll want to watch for other performance issues (extra CPU usage, other IO slowing, increased energy usage when backing up) after making that low level system tuning adjustment.

  • 4
    To change the setting live without restarting, use sudo sysctl debug.lowpri_throttle_enabled=0. Use the sysctl.conf to ensure that the change is kept after reboot. Jun 21, 2017 at 18:19
  • For me, this doesn't seem to be speeding things up past the ~5MB/s it was at before. I'm on Catalina, and moving data from an encrypted internal SSD to an encrypted Time Machine SSD over USB 3.1.
    – spacetyper
    Oct 1, 2020 at 2:10
  • Yes @spacetyper it never made things faster for me, but some people loved it. I should add most people seem to think it’s ignored on 10.13 and newer... what OS version did you test?
    – bmike
    Oct 1, 2020 at 2:24
  • @bmike This was on 10.15.6
    – spacetyper
    Oct 1, 2020 at 2:49
  • @spacetyper good points. Hopefully the edit makes this more helpful.
    – bmike
    Oct 1, 2020 at 11:39

Unfortunately, the solution in this case was:

Format disk (lose old backups)

Now the disk backs up at full speed.

  • Was it not formatted as HFS+J?
    – Harv
    Jan 25, 2011 at 1:15
  • It was and still is. Nothing changed, just wiped it and everything worked fast.
    – user588
    Jan 25, 2011 at 2:12
  • @mankoff How odd!
    – Harv
    Jan 25, 2011 at 6:04
  • 1
    It's no surprised that this would improve speed - you started again from scratch. Was the drive previously pretty full? How big is your TM drive compared to the total size of all the disks its backing up? I'd surmise that it was probably spending a ton of time 'thinning', which is throwing out in-between versions of files to make more room for newer versions. Have a look at 'Console' and put 'backupd' in the Search box. Scroll back to before you formatted.. any clues? Jan 25, 2011 at 22:08
  • Good suggestion. Drive was not full. Internal is 300GB used of 500GB. Backup drive was 500GB and had 71GB free. I've posted sample system.log output into the original question rather than here so it can be formatted properly. Doesn't seem to be thinning, but there may have been a spotlight issue, although spotlight was disabled on that drive.
    – user588
    Jan 25, 2011 at 23:52

According to this thread:

Delete the "in progress" folder on the TM drive and then things will operate at a normal speed.

Note: That did not fix the problem in my case.

  • Worked for me. InProgress file seemed locked and took time to delete.
    – AHHP
    Aug 18, 2016 at 8:12

You could try renaming the /.Spotlight-V100 folder on the TM volume. I've never tried this but Spotlight is used to decide which files are new/changed since the last backup. The only thing that comes to mind in reading your question, is maybe the index is broken and needs to be rebuilt, and TM in the mean time is running that search live, rather than indexed.

Long shot.

  • 1
    Deleting the .Spotlight-V100 folder and adding that drive to the System Prefs > Spotlight > Privacy list seems to have helped. I'll check if this works again on my other slow drive.
    – user588
    Jan 18, 2011 at 20:33
  • If it's worked, great. I'm not sure though if preventing the TM drive from being indexed properly is a good idea though. I suppose once the initial backup is done you could remove the drive from the privacy list and allow it to re-build the index.
    – Harv
    Jan 18, 2011 at 21:56
  • Not a good idea? Seems like an obvious flaw that they allow it to be indexed at all. Why would I want spotlight to index the backup drive?
    – user588
    Jan 19, 2011 at 1:17
  • Time Machine makes heavy use of Spotlight to determine which files need to be backed up.
    – Harv
    Jan 19, 2011 at 3:46

Add the Time Machine disk to the Privacy list of Spotlight (in System Preferences) so that Spotlight does not spend time accessing that drive.

  • Spotlight is an integral part of TM, and you can't stop Stoplight from indexing a TM backup. Adding the drive to the exclusion list will only affect other files outside of TM on the drive.
    – benwiggy
    Oct 1, 2020 at 7:05


In my experience, it's very common for the catalog B-tree to become very fragmented. On a volume that is both large and full, this type of fragmentation can have a significant effect.

At any time

Use the demo version of iDefrag to view statistics.

When the backup volume is as close as possible to full

Consider using the Metadata algorithm of the full version of Defrag, or a comparable utility, to defragment the catalog and other critical files.

(For a Time Machine backup volume, don't bother with full defragmentation.)

Other utilities

fileXray — this alone can not defragment the relevant files, but for analysis: I know of nothing better than fileXray.

Cross reference

Do Macs need to be defragmented?

  • I know this is an old answer, but is it safe to run iDefrag on a Time Machine backup (which has numerous directory hard links)?!
    – RJVB
    Apr 1, 2019 at 14:39
  • fsck_hfs -dyf -Race /dev/<disk#s#> will check the filesystem and rebuild attribute, catalog, and extent overflow tree. I tried it on a time machine drive multiple times and it does not break anything.
    – Joy Jin
    Oct 1, 2020 at 9:55

It could also be related to MRT process. For me, when I removed MRT process, backup speed becomes normal. By the way, MRT is sth called malware remove tool which comes with the security update and it will take lots of CPU to do scanning work. There are some articles on how to remove it.

  • 3
    Rather than mentioning there are "some articles" we prefer someone to answer with those articles summarized and linked so people can understand. The speculation about MRT seems spot on, but is that documented elsewhere either?
    – bmike
    Nov 13, 2012 at 22:48

You must log in to answer this question.