PostgreSQL now comes with Server on 10.8+. However, postgres seems to require restarting often. How can I keep postgres running without having to restart it so often?

  • 1
    What do you mean require restarting often? I've never had that problem. – Enrico Susatyo Sep 7 '12 at 6:27
  • 1
    If I don't hit the database for a while, postgres shuts down. It works fine after I do a "sudo serveradmin start postgres" but I have to do that quite often. – Erik Sep 7 '12 at 6:40
  • I have 10.8.2 with server and I don't see PostgreSQL as an option. Where is it? – user34600 Nov 12 '12 at 22:33

Not sure if it's the same in Mountain Lion Server, but perhaps this will help:

Disable automatic application termination in OS X http://hints.macworld.com/article.php?story=20120726192014497

  • Please consider providing some important and applicable bits of information from the provided link; it's best practices to provide information from links in context. – Ethan Lee Nov 16 '12 at 0:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .