I've tried installing postgresql, used the install pkg from EnterpriseDB 9.1.5, now psql isn't working. Seems to be a path issue, but now, there's the matter of libssl. Seems there is a new version, but how does one go about updating without MacPorts? Thanks

$ psql
dyld: Library not loaded: @loader_path/../lib/libssl.dylib
  Referenced from: /usr/lib/libpq.5.dylib
  Reason: Incompatible library version: libpq.5.dylib requires version 1.0.0 or later, but libssl.0.9.8.dylib provides version 0.9.8
Trace/BPT trap: 5

2 Answers 2


This is how I fixed this, it's based on a couple of threads on Stack Overflow.

sudo cp /Library/PostgreSQL/9.1/lib/libssl.1.0.0.dylib /usr/lib
sudo cp /Library/PostgreSQL/9.1/lib/libcrypto.1.0.0.dylib /usr/lib
sudo ln -fs /usr/lib/libssl.1.0.0.dylib /usr/lib/libssl.dylib
sudo ln -fs /usr/lib/libcrypto.1.0.0.dylib /usr/lib/libcrypto.dylib

Please take note of what the links you are replacing looked like before you overwrite them so you can put it back the way it was if it causes you grief. I am not convinced this is a good idea yet, but it's working so far. I'll edit if it comes back to bite me in the arse.

  • Can you link to the relevant threads on SO?
    – Cajunluke
    Sep 22, 2012 at 16:27

Turns out I was having a problem with homebrew, mainly pkg-config. Seems homebrew really doesn't like not being installed in /usr/local under Mountain Lion. Any way, moving out of ~/ and into /usr/local, re-brewing everything (since most things installed with prereq pkg-config). Manually removed the EnterpriseDB version of postgres, and a couple reboots later, got a nice working postgres, psql, and libssl running. If I run into any more errors, I may give your solution a shot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .