I don't know the rhyme or reason to it yet, but random calendar event notifications in Lion turn into drafts in my Mail.app drafts folder. I usually find these when I wake the machine up after it's been idle for some time.

Why would an alert become a draft in Mail.app at all? It makes no sense.

The calendar items are from a shared Google calendar. The draft is marked "no recipients", and just has the basic info from the calendar entry. The subject is like this:

"Alert - Piano lesson"

and the body is like this:

"September 5, 2012 1:45 PM : Piano lesson"

My wife enters those in HER gmail account calendar but I subscribe to it.

Any ideas?

  • I am having the same issue, except mine are coming from my work exchange server not google. This did not happen until I upgraded from Snow Leopard to Mountain Lion. They just keep coming, the same calendar event over and over, I have deleted at least 400 of these over the last week. Any help would be greatly appreciated.
    – user28682
    Sep 6, 2012 at 17:55
  • It would be helpfull if you look into the console and search for ical/calendar or apple Mail entries. Perheaps there is a clue to further analyze your problem.
    – J.C.
    Sep 6, 2012 at 20:22
  • What do you mean "look into the console". Do you mean some kind of event log? Where would I find that? Sep 7, 2012 at 19:20
  • @Sconner69: Microsoft Exchange utilizes email as its method for delivering and responding to calendar invites. This is extremely apparent using Outlook on a PC. I'm assuming your issue is not directly related to the Gmail issue the OP is having.
    – bispymusic
    Mar 3, 2013 at 0:39

1 Answer 1


Calendar invitations are delivered via email, so perhaps Mail app is preparing things for you to "accept, tentative, or decline" the invitations as part of the routine processing of a mail message that gets diverted from the inbox and places in another application (Calendar in this case, or iCal for those on Lion and earlier).

You could also just configure Calendar to not retrieve CalDAV events from Mail in the first place and let mail handle things in the inbox rather than having the system try to process things for you.

Calendar -> Preferences -> Advanced

Deselect the box next to Automatically retrieve CalDAV invitations from Mail

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .