I recently tried compiling Textmate 2 now that it's open sourced. Followed all the directions hereand downloaded all the dependencies. Now, when I tried to build (using ./configure && ninja) I received the following error:

make: *** [/Users/~/build/TextMate/Frameworks/SoftwareUpdate/fixtures/secret.pem] Error 1

[6/1169] Copy ‘"Frameworks/OakFoundation/src/NSString Additions.h"’…ninja: ERROR: mkdir(/Users/~/build/TextMate/include/OakFoundation): Permission denied

ninja: build stopped: .

Now, I figured that maybe Mountain Lion messed with permissions, so I gave it the ol' sudo try. I still receive a similar error -

rm /Users/jlvillalobos/build/TextMate/Frameworks/SoftwareUpdate/fixtures/secret.pem
[7/1169] Compile ‘Frameworks/scope/src/match.cc’…ninja: ERROR: mkdir(/Users/jlvillalobos/build/TextMate/Frameworks/scope): Permission denied

Now, I'm pretty stuck. I tried just checking my bash profile and I get a permission denied error on that too! I've ran "repair permissions" in disk utility for posterity and getting the same error. Anyone run into similar issues?

  • 1
    Where did you download the sources to (into which folder)? Did you set builddir manually? What is the output of ls -al ~/.bashrc and id -a?
    – nohillside
    Sep 5, 2012 at 4:57

3 Answers 3


Looking at the first error message from make it seems as if the paths got configured wrongly by configure. So just rerun it and make sure to specify any required paths in full (without ~).


When you're installing unix applications on MacOSX the installer needs to to be run as root.

Try typing

./configure && sudo ninja

or just

sudo ninja

given that you've already run configure.

All going well you should be prompted for your password (it won't print asterisks, just type the passowrd and press return.)

If this doesn't work it's probably because you don't have root enabled. Follow the instructions here to do that, then retry.


First thing: Never configure or make as root, unless there is a very specific reason.

Second thing: In make: *** [/Users/~/build/TextMate/Frameworks/SoftwareUpdate/fixtures/secret.pem] Error 1: This /Users/~/ looks HORRIBLY WRONG!

To change the ownership of the files back to you run

sudo chown -R $(whoami) ~/build/TextMate

Now do a

make clean && ./configure && make all && sudo make install

(make install is such an exception when you MIGHT want to use sudo.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .