My mid-2009 Macbook Pro, running Mountain Lion, very often does not wake up from sleep. When I open the lid, there is a black screen, but the fans are still running. My only option is to force reboot by holding down the power button. When It finishes rebooting, only half of the installed RAM is recognized - System Information shows that Bank 1 is empty when there is actually a stick of RAM installed. I have tried swapping out the RAM, booting from other disks, reinstalling, and searching for evidence in the log files, but the problem persists. The Apple Genius Bar didn't even know what was wrong with my computer. I am at a loss - what could be the problem?

  • You don't mention if the MBP ever uses the full RAM installed, and if so, what do you do to make it work.
    – IconDaemon
    Commented Sep 3, 2012 at 20:58
  • After a blackout, if I restart a few times, the full 2x4GB is recognized until there is another blackout.
    – 22222222
    Commented Sep 4, 2012 at 4:24
  • I have been having the same exact symptoms on the same model, to which I have administered the same fix attempts – to no avail. I'm glad to finally read about someone else having this issue. Have you made any progress in discovering the cause, or a solution? Any info would be greatly appreciated. Sorry I can't offer any myself.
    – user54737
    Commented Aug 8, 2013 at 18:22
  • It turns out the problem was in fact a faulty logic board. The computer, while four years old, was still in good shape so I had an Apple store ship it out and repair it for a flat fee of around $250. I had it back within a few days. If you decide to do the same, make sure you have them ship it out instead of repairing it in-house because if you ship it out they will repair any non-cosmetic damage for a flat fee.
    – 22222222
    Commented Aug 8, 2013 at 22:52

1 Answer 1


If you've tried reinstalling and resetting PRAM / SMC etc and it's still occurring on a clean install then that rules out a software issue. If you've tried another ram stick that rules out faulty ram.

Sorry to tell you, but it sounds like a motherboard issue, which means $$$. That's the only other thing I realistically think could be causing the ram fault.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .