13

I've setup a WiFi network to allow iOS devices (such as my iPad) to connect to other devices on the local network, but I want to be able to use the 3G functionality on my iPad at the same time to connect to the internet. How can I setup the WiFi so that the iOS device doesn't think there's an internet connection through it?

I've tried setting the DHCP Gateway to 0.0.0.0 but this just seems to confuse the iPad - the spinning circle next to the Wifi network never disappears even though it has an IP address from the DHCP server.

Update: I was able to set the DHCP Gateway to 0 and the Router entry now appears as blank, but the spinning circle still doesn't disappear.

Update: Setting the DHCP Gateway to 0 or 0.0.0.0 works fine for Windows, Android and Windows Mobile so I'm beginning to think this is an iOS bug. I've posted a question on the Apple iOS Dev forum here.

5
  • 1
    Not sure I understand - if you want to use 3G, why not just turn off Wi-Fi?
    – JW8
    Sep 3, 2012 at 5:36
  • 2
    If I understand this correctly you want your iPhone/iPad to connect via WLAN for addresses in your local network and via 3G for all other addresses?
    – nohillside
    Sep 3, 2012 at 6:32
  • Basically yes. The addresses in the local network will be discovered using Bonjour, but for anything else we want it to fall back to 3G.
    – parsley72
    Sep 3, 2012 at 23:43
  • 1
    I think Apple just nixed this ability in iOS 10. I followed all above instructions regarding static IP to a T and still no internet connection through cellular. :( Can anyone still verify this method with iOS 10?
    – chris
    May 23, 2017 at 17:20
  • iOS 10.3.3, haven't been able to make this work for me
    – arya
    Mar 8, 2018 at 4:21

3 Answers 3

17

You should define a STATIC address for the WiFi/LAN. (define an correct netmask, and dont enter any router/gateway address ). (see the static tab in the @Michiel's screenshot.)

When you done, you can access the computers on WiFi network and you will access the rest of the Internet via 3G.

This is what you looking for?

5
  • I should have been more specific. We want the Wifi to use DHCP so this isn't an option. How can I set the DHCP gateway to a value that the iPad will read as unset?
    – parsley72
    Sep 3, 2012 at 23:45
  • @parsley72 Why are you so set on DHCP? Unless there's something I'm missing, it's not going to be of a benefit to you in this situation. By the way, nice answer, @kobame! Sep 5, 2012 at 17:43
  • If you don't have DHCP then the iOS device takes about a minute to assign a zeroconfig address. This isn't a good user experience.
    – parsley72
    Sep 5, 2012 at 23:29
  • This is the right answer. Set the Static address to the address you received from the DHCP server, leave out the gateway. This is how I do it, works great.
    – dhempler
    Mar 7, 2013 at 23:32
  • I'm trying to setup a network on a product to sell to non-technical customers. Asking them to set a static address isn't very convenient.
    – parsley72
    Sep 21, 2013 at 3:52
5

This appears to be fixed in iOS7 - I set the DHCP Gateway to 0.0.0.0 and the iPad connects with a tickbox rather than leaving the spinning circle.

2
  • is this still working iOS8+ ? thanks
    – 3pic
    Jul 31, 2015 at 8:34
  • @3pic – yes it is (Tested on iOS 9 actually) See my answer below Sep 23, 2015 at 2:32
0

I was able to successfully connect to my Arduino's wifi and still retain access to the web, but I struggled following the instructions from the other questions and comments, so here is my explanation.


TL;DR

  1. Connect to Arduino Yun wifi
  2. Make note of the DHCP IP address and Subnetmask
  3. And use those values with Static IP

Long Version

There's lots of resources explaining the normal methods of connecting, but this is how to connect from an iOS device and still retain access to the web via cell network.

After resetting the Yun's wifi (hold reset button for 6-10 seconds), wait until the device finishes booting and it's wifi network is available.

Connect to the Yun network, and take note of the IP address and Subnet mask in the info view. Then switch to Static IP and enter the aforementioned IP and subnet mask.

You should now be able to connect to the arduino (arduino.local) and still access the web.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .