2

I disabled the built-in samba server in OS X 10.7.4 and I installed Macports' smbd, because it is much more reliable.

Unfortunately, the daemon does not start, I get this in console log:

02/09/12 22:07:17,901 com.apple.launchd: (org.samba.smbd[3032]) Exited with code: 255

What I can do? What can be the reason?

I tried to reinstall, but it doesn't change anything

sudo port install samba3
--->  Computing dependencies for samba3
--->  Cleaning samba3
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.

More info:

MyMac:LaunchDaemons user$ more org.samba.smbd.plist 
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
        <dict>
                <key>Label</key>
                <string>org.samba.smbd</string>
                <key>OnDemand</key>
                <false/>
                <key>ProgramArguments</key>
                <array>
                        <string>/opt/local/sbin/smbd</string>
                        <string>-D</string>
                </array>
                <key>RunAtLoad</key>
                <true/>
                <key>ServiceDescription</key>
                <string>samba</string>
        </dict>
</plist>

/opt/local/sbin/smbd -i
Unable to setup corepath for smbd: Operation not permitted
smbd version 3.6.7 started.
Copyright Andrew Tridgell and the Samba Team 1992-2011
PANIC (pid 3421): Could not init smbd's messaging context.

BACKTRACE: 6 stack frames:
 #0 0   smbd                                0x000000010a47d346 log_stack_trace + 54
 #1 1   smbd                                0x000000010a47cc31 smb_panic + 81
 #2 2   smbd                                0x000000010a2422cc smbd_messaging_context + 28
 #3 3   smbd                                0x000000010a69c9c9 main + 1961
 #4 4   smbd                                0x000000010a1c0334 start + 52
 #5 5   ???                                 0x0000000000000002 0x0 + 2
Can not dump core: corepath not set up

sudo smbd -i
smbd version 3.6.7 started.
Copyright Andrew Tridgell and the Samba Team 1992-2011
get_user_groups: failed to get the unix group list
create_local_token failed: NT_STATUS_NO_SUCH_USER
1

I solved in this way:

Wipe Macports from the HD per this guide, then use SMBUp to reinstall smb+all dependencies.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .