I have an iPad 2 and have used iMessages many times. For some reason now I can't message. The send button is not active. I'm trying to message a friend who has an iPhone and who I have messaged many times in the past. Any clue as to what to do?

I have force closed the app, powered off, checked the contact number, all to no avail. WiFi is active. Have gone thru all steps listed as possible fixes except deleting and reinstalling. I can't find iMessage in the App store so I don't want to delete because I don't know how to reinstall.

  • Is it possible that your iPad has quietly disconnected from WiFi/3G? – Nathan Greenstein Sep 2 '12 at 17:07
  • No, wifi active – Trudy Sep 3 '12 at 14:12
  • 1
    maybe the receiver haven't got the iMessage installed? – cekisakurek Sep 3 '12 at 15:20

you may have gotten help by now on this issue, but I had it just happen to me on my IPAD ( 4th edition). I called apple, and the tech walked me through a few things, but what really worked, was going to Settings/general/ scroll down to Reset and hit it then hit Reset all settings. You will then need to sign into your WIFI connection again, so go to settings/WIFI/ and pick your wifi connection and enter your password. Then when you are connected, go back to messages, choose one of your imessages and see if you can send. This worked for me.

Good luck.

  • This problem happens a lot, must be the iPad 4 as my daughter inlaw has iPad 3 and never has that problem. But Thank you, this resetting really works. – user44065 Mar 1 '13 at 6:17

In my experience, this will occur if the receiver has changed settings for one reason or another, and is no longer "signed in" to iMessage on the particular device that they used to be signed in on. Like if they restored their phone and neglected to set up iMessage with the same sign in that you had addressed previously.

  • Thank you, but none of my contacts work. The person I message most has not changed her settings or phone. Any other suggestions? Might it be a change I made? – Trudy Sep 4 '12 at 17:28
  • as you type the message, is it possible that you are typing into the subject field rather than the message field? see this for an example: 24.media.tumblr.com/tumblr_m9ua8kuEuk1qz4rlzo1_1280.jpg – dtheory Sep 6 '12 at 18:18

Turn iMessage off, hard reset your iDevice and then turn iMessage back on again and it will start working again! I've had this issue on more than one device, most recently after updating to iOS 6.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .