194

Spotlight has stopped showing any results for my Applications. I've tried reindexing and removing the index so it rebuilds it. No change. I've tried adding Applications to the Privacy tab and removing it, no change. I tried repairing disk permissions and redoing the above, no change. I've tried removing everything from the index except Applications and then I just get nothing for any search at all (except dictionary entries). I tried adding a symlink in my homedir to Applications and reindexing, but no change.

Any ideas on what to do? I'm running Snow Leopard. This is driving me crazy!

Update: I've noticed that when I start a reindex with sudo mdutil -E / and then immediately do a Spotlight search for an app that the app shows up temporarily until Spotlight gets disabled due to active indexing. After the indexing is done, the app entries go away.

  • Just a quick check: have you gone into system preferences and gone into the spotlight tab and customised the search results tab? In that tab you can check which items will be shown in spotlight. If applications are checked, make sure the applications directory is in the right place and send me the location – Jamesg Sep 1 '12 at 9:27
  • yes, it's checked, listed first in the list, and is in /Applications – mix Sep 1 '12 at 9:35
  • Could that be related to apple.stackexchange.com/questions/96183/…? – pstadler Sep 16 '13 at 13:09
316

Loading the metadata plist worked for me:

Turn off spotlight:

sudo mdutil -a -i off

Unload it:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Load It:

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Turn on spotlight again:

sudo mdutil -a -i on

Now everything is being reindexed as expected.

In newer versions of macOS, just turning indexing off then back on again resolves the issue.

  • 3
    if after sudo mdutil -a -i on indexing is still disabled please look at this answer – Camilo Sanchez Aug 13 '15 at 3:36
  • 3
    This solution worked for me on macOS 10.12.2 (Sierra). – Sean Jan 14 '17 at 22:53
  • 7
    Here is another solution: discussions.apple.com/thread/7356551?start=0&tstart=0 – Mackelito Mar 15 '17 at 21:41
  • 41
    I got a message saying Operation not permitted while System Integrity Protection is engaged while unloading, but apparently it's reindexing anyway and worked for me on 10.12.4. – Nobu May 13 '17 at 7:56
  • 61
    It worked. I DID NOT need to unload/load. All I did was turn it off and on. – mjezzi Jun 29 '17 at 14:48
75

Had this issue and nothing worked until I rebuilt the index using this in the Terminal:

sudo mdutil -E -i on /

As an alternative you can also use a free app called Alfred which has a lot more features.

(I'm not affiliated with Alfred in anyway)

Hope this helps!

  • +1 for Alfred...which just works. If it doesn't, it has some very easy-to-use Preferences and Settings interface. Not to mention, workflows. (I, too, am not associated with Alfred, just happier using it than a busted Spotlight). – harperville Jan 7 '17 at 17:16
  • 1
    This is the answer that worked for me when Spotlight stopped indexing my applications. The currently accepted answer did not. – inopinatus Sep 12 '17 at 22:12
  • 1
    Just typing sudo mdutil -E / did the trick for me on macOS 10.12.6 (Sierra) – Jakob Egger Oct 8 '17 at 18:11
  • When I first tried this, I got an error message about the index being read-only; but after I restarted my computer, this command worked, and fixed my index. – Mike Morearty Jan 23 '18 at 8:26
  • Alfred actually uses the Spotlight index, see no. 3 alfredapp.com/help/troubleshooting/indexing – Ronni Egeriis Persson Mar 12 '18 at 10:23
31

When I tried Anil's solution, I got:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
/System/Library/LaunchDaemons/com.apple.metadata.mds.plist: Operation not permitted while System Integrity Protection is engaged

Instead, I followed these instructions, and it worked:

  1. Go to System Preferences, Select Spotlight
  2. Go to the Privacy tab in the Spotlight system preferences
  3. Click the Plus button
  4. Press Shift-Command-C to reveal your hard drives (if they are not available otherwise), or simply navigate to your hard drive (most likely MacintoshHD)
  5. If you have more than one hard drive, hold the Command key and click your various drives to add them to your selection
  6. Click the “Choose” button to add them to the Privacy list
  7. Ignore the warning.
  8. Remove the hard drive by clicking the minus sign.
  9. Boom, no more sad days.
  • This worked for me. I was having trouble with the Slack.app application not being recognized as an application. After performing these steps the Slack app now works just like all my other applications in Spotlight. – Richard Hurt Jun 5 '17 at 13:49
  • I had the same problem with Safari, if you can believe it. I am in a highly secure corporate environment, and this is what I was allowed to do, and it worked. – Jeff Jun 5 '17 at 14:48
  • Just had this problem with Evernote and this solved it. Thank you @Senseful. – JamesWilson Jul 20 '17 at 3:11
  • This solution worked great! In fact I could not use the other ones because I cannot seem to be able to find the terminal without spotlight :P – kenik Mar 26 '18 at 21:57
  • @kenik You can find everything in the Finder app. – akashg May 11 '18 at 19:07
2

Have you tried removing the spotlight.plist in your user preferences. Similar problem with 10.7.5 and re-indexing wouldn't work until I moved the spotlight.plist to the desktop to be safe and then did a sudo mdutil -E / If that works you can delete the old .plist file.

1

Here's a BASH script to automate the boring stuff based on @AntonioR and @Anil's answers: : https://gist.github.com/Obaied/d8afbbce1b73481fbd0410c0897b6a87

#!/bin/sh
# Reference: https://apple.stackexchange.com/questions/62715/applications-dont-show-up-in-spotlight

sudo mdutil -a -i off
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
sudo mdutil -a -i on /

You must log in to answer this question.

protected by bmike Aug 15 '16 at 3:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .