16

My Security settings are set to "Mac App Store and identified developers". I'm still getting this problem though I've allowed the app to run more than once as an Administrator. Specific apps that are experiencing this problem are Coda 2 by Panic, PDFpenPro by Smile Software, and Firefox.

"Coda 2" is an application downloaded fro the Internet. Are you sure you want to open it? Safari downloaded this file on August 29, 2012

Panic and Smile Software are identified developers if I'm not mistaken. And Transmit by Panic opens fine without these warnings.

Any idea why this is the case?

  • And this is every time you launch these apps even after confirming the dialog? I'd try Repair Disk Permissions first in Disk Utility. – Gerry Sep 1 '12 at 8:37
  • @Gerry just tried that and found some permissions errors but unfortunately the problem still persists :( – blogjunkie Sep 1 '12 at 9:12
  • Have you tried rebuilding the Launch Services database? – Lri Sep 1 '12 at 9:16
  • Tried that and I got: -bash: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister: No such file or directory Is that the correct command? I'd appreciate it if you could repost in pastebin.com – blogjunkie Sep 1 '12 at 9:20
  • I edited the comment a few minutes after sending it. Stack Exchange inserts ZERO-WIDTH NON-JOINER characters in the middle of long strings without spaces. – Lri Sep 1 '12 at 11:44
20

Solved the problem! The quarantine metadata was not clearing correctly for some reason. I fixed this by doing:

sudo xattr -d com.apple.quarantine /Applications/Coda\ 2.app

Big thanks to Thomas Reed in the Apple discussion forums - Link to answer.

  • This was the answer I was looking for; it worked perfectly! Thank you. – bluebinary Apr 1 '16 at 5:01
  • The first time you open the file, right click on it and select open. In the future, the application will open without confirmation as it has been approved. – user584583 Jan 19 '18 at 17:56
  • Right-clicking and then choosing Open did not cause the warning message to go away for me even after multiple tries. It took this answer's command to solve the problem for me. – Macil Jul 22 '18 at 1:29
2

If other applications keep showing the dialogs, you could also try disabling the quarantine warnings completely with defaults write com.apple.LaunchServices LSQuarantine -bool false. It also disables the warnings shown by Gatekeeper even if it was enabled in System Preferences.

1

The first time you open the file, right click on it and select open. In the future, the application will open without confirmation as it has been approved.

"This is by far the easiest and most secure method...To open a file blocked by Gatekeeper simply right-click the file in question or ctrl-click, and in the menu which appears, select Open. A prompt will now appear asking for confirmation.

In future, the application will open without confirmation,You only need to do this on first launch. This method works for both the “x is an application downloaded from the Internet. Are you sure you want to open it?” and “x can’t be opened because it was not downloaded from the App Store” prompts, and leaves Gatekeeper enabled at all times.

SOURCE

http://www.idownloadblog.com/2017/04/20/fix-application-from-internet-gatekeeper/

https://www.unlockboot.com/application-downloaded-internet-sure-want-open/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .