As I got a new computer recently, I've been trying to get back the stuff that I need for work. However, a few applications (Hotspot Shield is one of them) that requires an installer to install it doesn't seem to work. It gets stuck midway through installation, saying "Waiting for other installations to complete..."

I've enabled Gatekeeper to allow any applications, but it's still stuck.

Why is this and is there a workaround?

Edit: Here's the output in console:

1/9/12 5:08:07.575 PM coreservicesd[33]: Application App:"Installer" [ 0x0/0x338338]  @ 0x0x7f9b686baff0 tried to be brought forward, but isn't in fPermittedFrontASNs ( ( ASN:0x0-0x33c33c:) ), so denying.
  • Have you looked into the Console? There might be more information about which Application is blocking the progress. Please post the relevant error messages here. – J.C. Sep 1 '12 at 8:47

"fPermittedFrontASNs" points to the new Gatekeeper Function Apple introduced in 10.8 and which changes the way background processes behave and are able to launch child processes that interact with the user interface.

The Gatekeeper-Rule "Allow Applications downloaded from: Anywhere" still has some restrictions, as an example at this Apple Support Page points out:

"Anywhere – Allow applications to run regardless of their source on the Internet; Gatekeeper is effectively turned off. Note: Developer ID-signed apps that have been inappropriately altered will not open, even with this option selected."

I don't know if that specific note applies to Hotspot Shield, but i have seen similar Problems with other VPN-related Software.

I suggest you deactivate Gatekeeper completely for the Installation of HotSpot Shield. You can do that in the Terminal with:

sudo spctl --master-disable

After that a restart might be necessary. You can activate Gatekeeper after the Installation with:

sudo spctl --master-enable

For more Options look at 'man spctl' in the Terminal. Please tell if that solved your problem.

| improve this answer | |
  • I think you need to add sudo in front of the command as mentioned in the man pages, and also you need to restart your computer before you can install it. Thanks. – theAmateurProgrammer Sep 1 '12 at 11:04
  • I have added your suggestions. Glad to be of help. – J.C. Sep 1 '12 at 11:09

In my case

sudo spctl --status


assessments disabled
| improve this answer | |
  • Hi and welcome to AskDifferent and thanks for your answer! Can you explain a bit more detailed what the commands do? – myhd Nov 14 '12 at 10:37

it did the trick for me trying to launch the Apache & MySQL packaged with MAMP by setting the ownership to the current user for the whole MAMP folder.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .