Yesterday my web host (Dreamhost) unexpectedly moved my email account to a new server. Most of my email clients didn't skip a beat, and continued to connect to the server and receive mail.

However, immediately after the server migration, Mail.app on my home computer stopped receiving mail. It continued to successfully login to the mail server, but did not find any email received post-migration. My assumption is that it was connecting to the old mail server.

Today, Mail.app fails to login to the mail server at all. My assumption is that the old server has now been decommissioned.

To me, it seems as if Mail.app has some sort of bad DNS cache, causing it to 'look' at the old server rather than the new one.

Steps I tried to resolve the issue:

  • Restarted Mail.app.
  • Rebooted computer.
  • Cleared OS X DNS cache.
  • Synchronized IMAP account with server.
  • Deleted email account from Mail.app, and recreated it.
  • Rebooted cable modem.

Not a spot of difference.

Is it possible that Mail.app is somehow caching DNS details for the email server, even after I clear the OS X DNS cache? If so, how could I force Mail.app to 'look' at the new server?

Setup: OS X Lion, IMAP email account

[SOLVED] See the comments for a description of the solution. The culprit was Avast Anti Virus.

  • 1
    Did the URL change? Have you tried any other mail clients? Do other applications correctly route to the URL (like using a browser or using telnet to connect directly to one of the ports)?
    – jmlumpkin
    Commented Aug 29, 2012 at 22:55
  • @jmlumpkin Thanks for the reply. I'm at work now, so can't answer your questions, but will try your suggestions tonight. Questions I can answer: 1. The server URL hasn't changed. 2. I cannot connect to the server URL (mail.f6design.com) via browser, but that has always been the case (no data returned to browser). Commented Aug 30, 2012 at 0:25
  • 1
    Try to use telnet to port 25. This will let you know if the remote machine its connecting to is responding on that port. Then you can help narrow down is it just Mail.app, or anything else.
    – jmlumpkin
    Commented Aug 30, 2012 at 0:44
  • OK, after some ping tests, locally and using a remote service, I'm of the opinion that OS X (or maybe my ISP or router?) has an out-of-date DNS cache. Pinging mail.f6design.com from my macbook = Pinging mail.f6design.com from ping.eu/nslookup =, which is what I get when pinging other domains on the same mail server. I've tried purging OS X's DNS cache, but to no affect. Commented Aug 30, 2012 at 8:17
  • Interesting - doing a DNS lookup using my router's inbuilt tools gives me, which is different to my macbook. So the macbook must be the one with the sticky DNS record... Commented Aug 30, 2012 at 8:21

1 Answer 1


This sounds like a DNS caching issue still. I know that most web browsers do cache their own DNS as well, and I am sure Mail does, but I think that cache empties after exiting.

I always try to telnet into port 25 on a remote mail server to test the connection when something is weird. Port 25 is for SMTP traffic, or what sends the mail. If you get a valid connection, you can actually interact with this interface. With your comments though, this probably did not work.

DNS is a very strange beast, because so many different services do many things, not to mention the different hardware on your network. In this case you have:

  • router
  • Mac, but DNS cache and hosts file

In the end, it sounds like you discovered this in your hosts file. I can't count the number of times (I do a bit of web dev) that I set something up in the hosts file and then got confused why something was acting wrong.

  • 1
    I do web dev too, and while DNS seems like voodoo magic to me, hosts files are very familiar ground. At one stage I had Avast set to scan my email, and it "thoughtfully" added the mail server to the hosts file. I'd forgotten all about it. Commented Aug 30, 2012 at 12:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .