Anyone run into "There is no connected camera" message while using any of the camera applications (Messages, PhotoBooth, Skype, etc.)? I tried force quitting all the applications that use the camera but with no luck. Even tried sudo killall VDCAssistant without any luck. Restarting the machine fixes the issue, but it is highly annoying to do so every day. I am running 10.8.1 on 2012 MacBook Pro.


From osxdaily:

  • Quit all open apps that may try to use the FaceTime camera
  • Open Terminal, found in the /Applications/Utilities directory in OS X
  • Enter the following command string exactly, then hit return:

    sudo killall VDCAssistant
  • Enter the administrator password when requested, this is required to execute a command with superuser privileges as prefixed by sudo

  • Relaunch the app that was attempting to use the camera

Or... Use Activity Monitor, search for VDC and force quit it.

| improve this answer | |

If the issue is not Application-specific, nor User-specific, and your computer clearly recognizes the iSight, you should try reseting the SMC.

To do so, just:

  1. Shut down the computer.
  2. Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.
  3. On the built-in keyboard, press the (left side) Shift+Control+Option and the power button at the same time.
  4. Release all the keys and the power button at the same time.
  5. Press the power button to turn on the computer.
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .