My iTunes library has well over 25,000 tracks in it, and so I have to use this workaround in order to use iTunes Match. sigh Fine. So I've created the dummy library, and now I have to populate it with the tracks that I want to sync with iTunes Match. I don't want to do this track-by-track, so I'd like to create a Smart Folder of tracks that I can then import into the dummy library.

I want to sync my AAC files, but not my Apple Lossless files (because I don't want iTunes Match replacing the Apple Lossless files with the lower-quality iTunes Store versions). But when I create a new Smart Folder and specify the Kind to be Music and the codec to be AAC, it includes both the AAC files (which I want) and the Apple Lossless files (which I don't want).

How can I create a Smart Folder containing just AAC files that aren't Apple Lossless files?

Update: Here are some screen shots:

These are the current Smart Folder settings: enter image description here

And here's the info for two tracks, both of which are Curtis Mayfield's "(Don't Worry) If There's A Hell Below We're All Going To Go", the first one encoded as a 256 kbps AAC, the second as an Apple Lossless (For the curious, I rip my CDs as Apple Lossless for listening through my home stereo and then convert them to 256 kbps AAC for use on my capacity-limited iPhone).

Here's the AAC version:

enter image description here

And here's the Apple Lossless version. Note the much larger file size:

enter image description here

So: As you can see from the Smart Folder settings screen shot, both of these files are included in the Smart Folder, even though only one of them is actually an AAC. The thing is, both AACs and Apple Lossless files have a .m4a extension, despite the fact that they're different codecs. From Wikipedia:

Apple Lossless data is stored within an MP4 container with the filename extension .m4a. This extension is also used by Apple for lossy AAC audio data in an MP4 container (same container, different audio encoding). However, Apple Lossless is not a variant of AAC (which is a lossy format), but rather a distinct lossless format that uses linear prediction similar to other lossless codecs.

Hope that helps, and thanks in advance for any insight you can offer.

  • Can you include a screenshot of your smart folder settings?
    – Daniel
    Aug 27, 2012 at 23:15
  • When I try to replicate, I don't get Apple Lossless files in my AAC smart folder.
    – Daniel
    Aug 27, 2012 at 23:19
  • @DanielLawson Thanks for trying to replicate the problem. As you requested, I've included some screenshots, along with a bit more info. Thanks again for your effort; I hope the screenshots are helpful. Aug 28, 2012 at 0:12
  • The key problem here is that the codec isn't embedded in the file's metadata, so Smart Folders cannot detect codecs for m4a files. There is actually a codecs filter, but you can't use this without the metadata. My second thought was to use bit rate and pull files with a bit rate of less than 256, but this failed as well for the same reason. Very interesting question. Aug 28, 2012 at 0:33

1 Answer 1


When you create your Smart Folder, Set Kind to Music » All

Then, add an additional field. When prompted for what you are searching for in the first column, select "Other" then pick "Codecs" from the drop-down list:

enter image description here

The resulting Smart Folder should include AAC files but not Apple Lossless ones.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .