18

The trackpad on my Macbook Pro just started acting oddly. It's randomly clicking (which might cause me to switch programs), right-clicking and even once my screen even showed the swiping animation as if I was trying to switch to a different desktop.

Part of me fears that this is some sort of joke hacking attempt (I know of a USB device you plug into someones computer and it randomly moves their mouse and types on their keyboard), but there is nothing plugged into my machine and I just turned off the Wi-Fi and watched as this web page tried to close, the mouse right clicked twice, highlighted a word and clicked "Paste and Match Style" in the Chrome right-click menu.
Also as I've been typing (with my Wi-Fi turned off) the mouse has randomly been clicking inside this question and changing where I am typing.

I just plugged in a USB mouse which seems to work fine but the trackpad is now nearly useless. I can't even move the mouse cursor more than a few centimeters with it.

Is this a common issue?
EDIT
I think it is dying actually. I can now click but not move at all with the trackpad, while a regular mouse works fine.
EDIT 2
And now it seems to be working again. I turned on the option for "Ignore Trackpad when Mouse is plugged in" under Universal Access. I cleaned the trackpad with rubbing alcohol, I whined and complained for a few minutes to my dog, turned off the "Ignore Trackpad" setting, unplugged the USB mouse, and the Trackpad appears to be working mostly normally.
If I run my finger across it at the top or bottom portion of the mouse, it works, but there is a line horizontally across it (almost exactly where a physical trackpad button would end on the old trackpads) that is "dead". The mouse stops moving, or moves sluggishly when hitting that spot and that "spot" goes across the whole trackpad.

  • Is the laptop plugged in to a power source while the cursor jiggles? – duci9y Aug 27 '12 at 14:02
  • @duci9y : It has not been plugged into a power source, no. – James P. Wright Aug 27 '12 at 14:05
  • Do you touch the metal parts of the MBP while using the trackpad? Any metal part. Even the desk below the laptop, if it of metal. – duci9y Aug 27 '12 at 14:06
  • @duci9y : Nope. Look at my latest edit. The "dead line" is now the only part not working. I think that there may be some issues going on inside the laptop at this point. – James P. Wright Aug 27 '12 at 14:09
  • You should not clean it with rubbing alcohol, that wears out the paint. – duci9y Aug 27 '12 at 14:11

11 Answers 11

9

Your trackpad is definitely dead. It needs a replacement. The dead line means that it is slowly dying. I have had these things. Probably your connector is getting old. But mine got burnt up because the hotel I was staying in did not have proper grounding in their mains supply. This meant that current was flowing from the metal parts and trackpad (it is electrified), through my body, and onto any grounded metal surface I touched. Trackpads are very sensitive to current changes as they have very thin wires running through them. The high ground current burns them off, either row by row or column by column.

  • I've just come back to this question to say that oddly, the day after asking this question, the trackpad started working perfectly and I've had 0 problems with it since then.....so it's possible some wire inside was shorting out? shrug – James P. Wright Apr 19 '13 at 18:04
  • Yeah, possible. At least it was just the wires. – duci9y Apr 20 '13 at 6:11
30

This was driving me crazy, too. It just started happening yesterday, but was dangerous as the cursor kept selecting everything--making selection rectangles especially on the desktop, opening programs I didn't want to open on the dock, and generally jumping around like a drunk rabbit.

Searched forums, read about others saying this happened to them after updating their Mac software, etc., etc. Got so frustrated I literally slapped the trackpad with my open palm. And what do you know -- that fixed it! Now my trackpad is working perfectly again. Must have been something pinching or pressing against the underside of the trackpad.

Don't know if you're all going to believe me 'cause it sounds ridiculous, and if you do believe me I don't know if you're willing to do it. But I swear on my soul it's true and I'm posting this solution for all to see because I want to help.

  • 3
    thats brilliant! I literally put some extra pressure on the track pad with the palm of my hand and it actually fixed my problem! unbelievable, but hey. whatever works.. – hajpoj Oct 9 '13 at 22:08
  • 1
    Worked for me too! Excellent. This goes to prove that physical violence and computers do go well with each other :) – JHollanti Mar 9 '14 at 14:05
  • 4
    Contacting the trackpad with a wide surface area of skin, i.e. your palm, resets the detection of touch for the trackpad, no need to slap it. – Fyrefly Jul 1 '14 at 15:13
  • 1
    This worked for me as well. I think the trackpad got wet when some condensation dripped from a glass I was using. Shortly afterwards the trackpad went crazy and the laptop was unuseable. An external mouse fixed that and the trackpad did seem to get better over time (drying out maybe?) but it was still jumping up and down vertically on its own. A firm slap with the palm of my hand has fixed it. I confess I don't understand why, but it definitely worked. – Mark Thomas Sep 20 '14 at 5:59
  • 1
    This should be the accepted answer – Taha May 20 '15 at 9:41
3

Here are suggestions to try:

  • Make sure your trackpad is clean and dry, and you fingers not wet.
  • Try to restart your Dock service by typing in Terminal: killall Dock command (be aware, it'll restart/re-open all your windows). Here is another similar command to restart it:

    launchctl stop com.apple.Dock.agent && launchctl start com.apple.Dock.agent
    
  • Quit/restart any mouse related software (like BetterTouchTool).

  • In System Preferences, Trackpad, slow down your Tracking speed and re-enable all options.
  • Try to reset the System Management Controller (SMC).
  • If the problem still continues even after restart, it could be a hardware problem.
  • 1
    Slapping the trackpad sort of worked for a moment. But not for long. I tried the killAll Dock command and the other one, then reset the SMC. That worked. In my case the problems occurred after the laptop had been in a drawer, turned off, for two weeks, which is exceptionally long for me. – Wytze May 14 '18 at 8:50
1

The solution I found on iFixit was to press hard on opposing corners of the trackpad. Just once was enough.

I had the jumping cursor problem after leaving the Macbook Pro (mid-2012 13 inch) in a drawer for two weeks, which is unusually long for me.

The problem consisted of the cursor moving by itself, but there were also pinching motions, text selecting and taps going on that didn't come from my fingers. Or from a combination of my finger and the trackpad itself. At some points, part of the trackpad seemed to be dead. But not always the same parts.

Just pressing hard on opposing corner has solved the problem... at least for the last hour. Of all the other solutions I've tried, only slapping helped, but only for a few minutes.

0

The trackpad slapping with my open palm works !

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    Could you clarify your answer? I'm not sure I fully understand what you are recommending the OP do to fix his trackpad. – bassplayer7 May 3 '13 at 13:34
  • I wouldn't slap a stuck trackpad. They are made of glass and if you have a mis-alignment or piece of sand stuck, you will bend the springs or shatter the trackpad. I suppose if you slap it hard enough, you will damage it even if there isn't a mis-alignment or foreign object stuck within. – bmike Mar 24 '15 at 1:55
0

Today I had a horizontal line not working on the touchpad. I fixed it by removing the touchpad from the laptop (which is very annoying and requires a miniature screwdriver) and cleaned it with a lot of ethanol (ethyl alcohol) and a piece of cotton. I put it back in and it now works perfectly.

I have had a similar problem a couple of years ago and I didn't have a special screwdriver (that I do have now) and I fixed a similar problem with a syringe with ethanol and squirted the ethanol in the crack around the touchpad.

I have seen many people suggest to change the touchpad, but you can try with a cloth and ethanol (remove the battery and charger if possible and wait for 30 min for the ethanol to evaporate).

0

This was fixed -- and remains fixed -- after a third internet Reinstall.

Done through the Recovery Partition, start up with Command R.

  • What is an internet reinstall? – oarfish Aug 9 '15 at 7:56
  • It's accessed in your Recovery Disk. Does not affect user accounts, but backup computer first. SuperDuper or Carbon Copy Cloner will clone your disk to an external drive. Fast connection means about 20 minutes download, and then it installs itself. – Zo219 Aug 15 '15 at 23:35
  • See Apple Support document at support.apple.com/kb/PH18872 - OS X Yosemite: Reinstall OS X – Zo219 Aug 15 '15 at 23:37
  • So you mean internet recovery, that wasn't obvious for me. But you don't need internet recovery if you boot from your recovery hd, as you describe. – oarfish Aug 16 '15 at 7:12
0

If you are on macOS Sierra, clearing the login items worked for me. To do so:

1. Try safe mode

  1. Turn off your Mac.
  2. Press and release power button. Then, press and hold left shift until the login screen appears.
  3. Enter your password and wait for your Mac to log in. Right now, your Mac will start in the safe mode. Note that starting in safe mode can take considerably longer. Mine took around 5 minutes or so, maybe longer.
  4. Check if you are not experiencing the issue on safe mode. If you are not experiencing the issue on safe mode, then:

2. Clear your login items

  1. Open System Preferences -> Users & Groups.
  2. Click your account name and select Login Items
  3. Remove everything in this list by selecting them with cmd+a and clicking the minus sign.
  4. Restart your Mac.

The issue should have gone now.

Sources:

-2

I've heard dust and dirt inside the MB/MBP can cause the trackpad to act very weird. I'm having issues with my mouse now and am thinking of taking apart my MBP and blowing it out with a compressor.

-3

Nothing just go to system pref. , click over trackpad setting , in point and click select only the first one tap to clik , after that 2nd scroll & zoom click only the first one, 3rd box leave all blank no selections..... Now your mouse'll work as you command

  • This recommendation worked for me. – Konrad Rudolph May 17 '15 at 16:13
-4

Shift/control/option and turn off the computer wait 10 secs and then start-up,it should stop that annoying cursor.

  • Can you add some detail about what this does / why it works? – Kevin Chen Jan 13 '13 at 6:25

You must log in to answer this question.

protected by gentmatt May 3 '13 at 11:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .