0

I was trying to launch a few Java applications using the terminal. The command that I was instructed to launch it with (I was following a guide) was the following:

#!/bin/bash
cd "$( dirname "$0" )"
java -Xmx1024M -Xms1024M -jar craftbukkit.jar

It worked the first time, which was a test run, so I hide the terminal window to work on some other things. But when I opened the terminal window back up again, I noticed that I had lost my root@pcname:~$ prompt that usually starts with my terminal opening up.

I have tried to kill anything running in the background but nothing seems to work. When I enter a command it just moves me to the next line without executing anything. Please help and answer in simple terms, as I am not incredibly Terminal-savvy. Thanks!

migrated from askubuntu.com Aug 24 '12 at 21:02

This question came from our site for Ubuntu users and developers.

4

Your command is still running. Type Ctrl-Z to get your prompt back, followed by bg and Enter to let Minecraft continue in the background.

If you want to avoid similar issues in the future, call either the shell script itself or at least java with & at the end to put it into the background directly:

java -Xmx1024M -Xms1024M -jar craftbukkit.jar &
0

It would be help to see the guide you have been following. It seems like you started a bash script.

If you want to simply regain root rights use sudo su.

You can also use whoami to verify your username you are currently logged in on the terminal.

-1

type

su

and enter the root password, or better, use sudo in front of java -Xmx1024M -Xms1024M -jar craftbukkit.jar

  • 2
    And how exactly does this solve the problem described in the question? – nohillside Aug 25 '12 at 7:10

You must log in to answer this question.