I recently upgraded a 2010 MacBook Pro to Mountain Lion, and it's worked fine for the most part. Today, however, upon waking up from sleep, the laptop won't go past the login screen. I enter the correct password, hit Enter... and the focus on the password box goes away, and nothing happens.

Note that the password box doesn't shake, as it does when the password is incorrect. I'm entering the right password, it just won't dismiss the login screen.

Anyone else have this problem, and find a solution other than a hard reset?

(Unlike this question, three-finger swiping accomplishes nothing.)

  • Does the input field remain empty when you enter the password? For some time I had a problem with my Macbook that it wouldn't accept any input right after waking from sleep. Only letting it go to the blank screen and waking it up again would allow me to enter anything.
    – xeophin
    Commented Jun 12, 2013 at 17:10
  • It happens with my mac too. I tried to inspect system logs but didn't find anything suspicious there.
    – Dmytro
    Commented Dec 21, 2013 at 13:53
  • That happens sometimes on my mac and only entering password 4 times in a row helps :(
    – Aldekein
    Commented Feb 6, 2017 at 9:54

6 Answers 6


It looks like that User's folder got corrupted somehow, and the System doesn't know what to show and load, as It wasn't there.

Try logging with other user or a Disk Repair / Repair Permissions, through the Recovery Partition.


I get this as well. The only workaround is to do a hard reboot. Even logging in as guest user, then logging back to your regular user doesn't work.

It's not a user folder corruption issue as the Thecafremo says because I (and it sounds like, you) can get in after a hard reboot. Also, I recently happened to do my period disk volume repair and this issue recurred after the repair process.

  • 1
    This is a seldom but still recurring problem that happens for me as well, that a correct password won't let you in after sleep mode. The only workaround is to restart or do a hard reboot and you can log in without any problems again.
    – Spoike
    Commented Apr 21, 2014 at 9:35

Turn on the computer, while booting hold Command + R.

When you reach the recovery screen, go to terminal, it's in Utilities ▹ Terminal.

Type 'resetpassword'.

A GUI should appear and guide you through the process, this could likely refresh the corrupt files which are causing your inability to log in.

You may also find luck in trying to boot holding shift, (recovery mode).

You should also repair your permissions.


Well, try not capitalized and capitalized. Or just restart it. Maybe you could bring your MacBook to an Apple Store or where you bought it ( what I highly recommend or if all of the ideas don't work ).


If you can't sign in after running turn on the computer, while booting hold cmdR.

When you reach the recovery screen, go to terminal, it's in Utilities ▹ Terminal.

Type resetpassword.

and you reset the didn't work for your account.

Re-run the Recover Partition: cmdR Change the System Administrator account "root" reboot You should now be able to login as a other user Click other user username: root password:

From there you are now login as an admin open user & groups change your account password Log off and into your account.

  • Your answer is difficult to read and hard to understand!
    – klanomath
    Commented Jan 11, 2016 at 3:40
  • Also, can you expand on the need for enabling the "root" account to solve the issue described in the question?
    – nohillside
    Commented Jan 11, 2016 at 7:19

To prevent all of this, I recommend to create two admin accounts on your Mac. So if this problem comes, you can delete the damaged account and still log into your Mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .