I use Time Machine to make backups of my computer. Now I would like to mirror the complete backup to a remote machine for added security.

Here's my rsync command:

rsync -azvH --progress --partial --delete -e ssh /Volumes/2tb/Backups.backupdb/ user@remote:/backup

I use -a to preserve timestamp, -z for compression, -v to get verbose output, -H to preserve hard links (essential to copy Time Machine backup), --progress to see what's happening, --partial keeps partially transferred files, --delete removes files on remote that are deleted locally.

When I run this, I get a lot of file permission errors. Apparently, I'm not allowed to access a lot of files in my Time Machine backup. This is not only for files in /private, but also files in /usr/ which should have read permissions.

  1. Does Time Machine change file permissions while doing a backup?
  2. How can I use rsync to mirror my complete Time Machine backup without using sudo?

1 Answer 1


This site is devoted to answering questions about Apple Products, but it's aimed more towards comsumers than power users. That doesen't mean your question is "wrong" in any way or you should remove it, but I strongly reccomend to ask it at the Super User Stackexchange site, which is devoted to power users like you. I think you might find there someone who can answer your question much sooner than here.

  • 1
    Good point! The question is kind of answered anyway: rsync can't preserve hardlinks when copying to a different filesystem. In my case I tried to copy from HFS+ to Ext3 via SSH. There are workarounds though: bit.ly/R7DMcL Sep 5, 2012 at 12:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .