1

I have a 2010 MacBook Pro with OS version 10.7.4 Recently, the wifi connection stopped working on my home network: it fails to get an IP address.

Everything's fine if I assign an address, the other devices on the network are working fine and the Wifi connects without problems to other networks. Ethernet connection to the same network gets an IP address and works. It's just WiFi on that specific network (which used to work, too).

Wireshark shows that the client is sending out discovers and the server is answering with a lease, but the dhcp client seems to ignore the lease.

I already tried the usual PRAM and NVRAM and PMU with no luck. I also tried to remove the /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist, but with no changes.

Any ideas?

2
  • Is the DHCP pool big enough?
    – Thecafremo
    Aug 23, 2012 at 9:34
  • yes it is, and an answer arrives from the dhcp server, offering an IP address, but the mac dhcp client just ignores it.
    – garph0
    Aug 23, 2012 at 10:11

0

You must log in to answer this question.

Browse other questions tagged .