After upgrading to ML, my iMac freezes when going to sleep. The fan goes off but i can't not wake it up. Its that weird i need to unplug the power, and then i can start it again.

Keeping the power-on button pressed is not working.

It does wake-up from the screensaver, but then the mac isn't asleep (yet).

UPDATE: after i set the "Computer Sleep" to never, and "Display sleep" to 30 mins. I did had the "hdd to sleep" and "wake-up" LAN checked. I still got a black-screen, and complete froze, noway to wake-up the Mac. Unplugging the power for a restart.

  • Does the problem go away if you disconnect all external devices before putting it to sleep?
    – Gilby
    Mar 5, 2013 at 9:57
  • its a iMac, no devices (except mouse) is connected.
    – Roger
    Mar 5, 2013 at 12:30
  • Hi all, a quick update. I'm pretty sure that the problem lies in the h/w. The part that takes care of power management seems (its a guess) to create this problem. The Mac starts fine, but after 10 minutes or so it freezes (screen goes black) and i can only restart by unplugging the power. Thanks for all your thoughts and tips!
    – Roger
    Oct 22, 2013 at 22:50

4 Answers 4


Please try resetting PRAM and SMC. Also, you may want to run Disk Utility to perform a validate and repair on your permissions and disk to see if that helps.

  • Tried that, but no joy. I talked to Apple Support. Their way is to reinstall (after PRAM, etc.). But it feels like a h/w issue, maybe EFI bios?
    – Roger
    Aug 20, 2012 at 20:57

Reseating the RAM is certainly easy, and a real fix to many arcane power problems. Let us know if you've done that.

This seems to be iMac-related, I see a lot of similar posts around the web. If it were mine, I would be certain to remove any special Sleep or Hibernation setting, whether input by command line or via a 3rd-party Preference Pane.

If reseating RAM didn't help ... did you know, resetting P-RAM (NVRAM) and the SMC - Power Manager can be repeated ... and repeated. Especially the SMC.

The other thing to check is whether your second User Account -- which you did create for Fast User Switching, to test things like this, didn't you -- shows the same problem. Therein lies a clue.

And I would not own a Mac without also owning Disk Warrior. The go-to repair after Disk Utility. You've run DU from another startup source, right? Repaired disk and permissions?

Aha, so Apple is the one recommending a reinstall for every fix. Overkill, but I guess easier for them.

Keep trying - and uncheck that wake on LAN and anything else but the simplest sleep and wake. I highly doubt this is a network OR app problem, just a stubborn power glitch or setting the machine isn't letting go of.


I'm copying in my answer from another post as the words "Mountain Lion", "Freezes" and "Sleep" instantly raise a few flags for me that suggest its all the same issue:

I'm going to take a wild stab in the dark guess and say that this is related to the highly documented "Mountain Lion wake bug" (at least that's what I've dubbed it.)

It's been discussed in a variety of threads on apple support forums, but probably the most successful I found was this one. I had the problem too and I found that there was one simple fix on this thread.

Basically, the theory (and I'm 99% certain it's correct) is that the bug relates to bonjour, and some apps that use bonjour in mountain lion are causing wifi processes to hang and thus crashing OSX. Anyway, the program that was doing it for me, and probably what I've seen to be the most common one, is Transmit, the awesome little FTP client by Panic. Unfortunately, Panics Menu Bar icon which can be quite useful appeared to be the worst culprit, but toggling off "Show Transmit Disk in menu bar" in transmit preferences solved the problem.

If you're not using Transmit or if you're still having issue, run through that forum and hopefully you'll find one of the other fixes works for you.

PS. Apple knows about the problem and I think they're working on a fix.

  • thx. I'm hard wired. And its a pretty clean install. I know Transmit (have ML on my MBA without any problems). I have to UNPLUG my power to get it started... :( I go read your links!
    – Roger
    Aug 20, 2012 at 21:05

PCIRootUID=1, this may fix this problem. If not, try reinstalling the FakeSMC.kext.

  • 1
    Can you add some details about where to add this statement and what exactly it does?
    – nohillside
    Sep 30, 2013 at 5:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .