My mac mini with OS X Lion Server 10.7.4 is running headless in a data center so its not physically accessible. As administrator, I can connect to the server using SSH and other administration tools, however, I'm unable to connect to the server from OS X Lion 10.7.4 using screen sharing. It refuses to accept my credentials. I tried to reboot the server, but it still doesn't work.

The logs indicate the following (server name, username and ip address obfuscated):

Aug 20 00:25:35 myserver screensharingd[28041]: Authentication: FAILED :: User Name: My User :: Viewer Address: :: Type: DH

I had no problem connecting to my server using screen sharing before, however, this was several months and service updates ago. I generally connect to the server using SSH or admin tools to perform updates.

Any idea what could be causing screen sharing not to work? Better yet, any suggestions how to address it using SSH or admin tools?

  • Have you tried restarting the server? – afragen Aug 20 '12 at 16:50
  • Several times. Even fixed permissions. – bloudraak Aug 20 '12 at 20:15
  • I have this problem. I can't use screen sharing or remotely use Server.app, but I can use SSH and log in to the box directly. I'm currently speculating that it's a Kerberos problem. – Amy Worrall Nov 28 '12 at 16:51

You must log in to answer this question.

Browse other questions tagged .