My Macbook Pro running Mountain Lion slows down dramatically when the battery is below 4-5%. All the applications running are very slow to respond, and several have the "Application not responding" message when I right-click on them in the dock. Now everything works fine when the battery is above 5%, so I'm wondering what goes on when the battery is low that causes the performance drag. Basically, I have two questions:

  1. What is causing this lag (for the sake of curiosity)?
  2. How can I fix it (for the sake of practicality)?

System Info:

  • Device: Macbook Pro (Spring 2012) 13-Inch running Mountain Lion (10.8)
  • Memory: 8GB
  • Processor: 2.8 GHz Intel Core i7
  • Storage: 500GB SSD Drive with more than half free
  • 2
    It sounds like CPU speed stepping to me. – ephsmith Aug 19 '12 at 23:16
  • 1
    has the provided answer solved your problem? Because I don't see any of the described settings in 10.8 – barbaz May 1 '13 at 8:56
  • 1
    @barbaz - It didn't really solve the problem, but it seems like there is no solution so I accepted it. – pasawaya May 1 '13 at 12:06
  • Same problem with MacBook Air 2013. – KPM Nov 20 '14 at 12:47
  • 1
    I'd really like to find a solution to this, it's annoying for me as I can't do any work with the last 10% of battery life, so it's effectively dead anyway. – Tom Jul 29 '15 at 8:22

See if this link provides you with some useful knowledge. http://smallbusiness.chron.com/change-processor-speed-macbook-pro-43635.html

It's likely that the MBP is automatically scaling the processing power back to conserve battery power, but that isn't necessarily the only cause.

| improve this answer | |

This is normal, the same thing happens on my MacBook Air (11 inch, 2014) when the battery gets around 5%, performance drops significantly, it does this because your battery level is so low, just plug it in a charger and it will start working normally again. If this doesn't solve it, try resetting the SMC.

| improve this answer | |
  • 1
    Soooo is there a command I can run or a kernel change I can make to prevent this?? – s g Jul 9 '16 at 0:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .