I noticed this with TrueCrypt volumes. Before 10.8, whenever I mounted a .dmg on my iMac, I could access it automatically from my mbp over the network with afp sharing. But after upgrading to Mountain Lion, apparently this is not working anymore.

Furthermore, I if explicitly share the mounted .dmg, I have no error on the iMac , but on the mbp the share is not visible. It's only me or this is a new "feature", may be related to security ?

2 Answers 2


I've got the same problem.

I used a .dmg mounted on my imac to store time machine backups for my macbook pro over the network.

Since upgrading to mountain lion I'm unable to access the network share from other macs. This seems to be the case for all .dmg files that I've tried to share over afp.

  • I searched the net but with no results, and I am surprised no other has noticed this. I am using SSHFS and MacFuse to access the iMac, it works but I hope this feature will be restored.
    – castigli
    Aug 21, 2012 at 7:58

Please file a bug report to apple. I have the same problem and have reported it.

I tried encrypting whole disks as well both with the built in tools and with truecrypt. I even tried to share a folder within my filevault to others but it doesnt work. The last thing I am not sure if it has worked, but I think so.

Very strange behavior either from the bug or from apple if it is intended this way.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .