I've just upgraded my bootcamp partition from Windows 7 to Windows 8 RTM on a MacBook Air (2011 Core i7) and have been utterly and entirely unable to get the touchpad to work.

Things I've tried:

  • Uninstalling and re-installing the Bootcamp package
  • Removing and adding the specific two touchpad devices in Device Manager

The touchpad worked correctly under Windows 7 and works under OSX, so this appears to be a Bootcamp/Windows8 issue, rather than a hardware problem.

Any solutions?

  • I'm not sure but don't I think Apple have released any support to run Windows 8 on Mac yet as it's not officially released.
    – Hoshts
    Aug 18, 2012 at 18:11
  • @Hoshts, Windows 8 has been officially released and is available to people with "volume licensing" agreements and similar =) That said, you may be right that Apple need to make tweaks to their drivers to be fully Windows 8 compatible - in lieu of that I'd be more than happy to try anything anyone can suggest though! =)
    – Rob
    Aug 19, 2012 at 21:14
  • I have the same issue with my MacBook Pro's trackpad in Windows 8: No detection at all, and Device Manager reports an error when trying to update the drivers.
    – mcandre
    Oct 29, 2012 at 20:53
  • @mcandre - try the steps in Ryans answer (apple.stackexchange.com/a/63098/22271) - they worked on another machine to resolve the error when updating the drivers issue
    – Rob
    Oct 29, 2012 at 20:55
  • @Rob I found a solution. superuser.com/a/495821/5142
    – mcandre
    Oct 29, 2012 at 21:27

5 Answers 5


Go to Device Manager and uninstall (and delete drivers) for the two Trackpad devices then rescan for hardware. After which, then go find your Boot Camp drivers, and don't run the full setup, but instead find the folder that specifically has the driver install packages in them and install the ones that are along the lines of "Apple Multitouch Trackpad." After this, go to your Boot Camp options to make sure that it now sees your Trackpad. You should have full functionality restored after this.

Did get the answer from this forum post: How do I get my Macbook Pro trackpad working on Windows 8

  • 1
    My touchpad appears to have spontaneously started working again after performing this sequence of events and rebooting. I'm not sure if that's what fixed it, but the accepted answer's yours =)
    – Rob
    Aug 23, 2012 at 7:00
  • This answer is incomplete. Where are the drivers located?
    – Nash
    Oct 26, 2012 at 21:53
  • @xeon See in the forum post the answer of Rys Towey: I then installed the drivers included in the Bootcamp 4.0 folder called "AppleTrackPadInstaller.exe" and "AppleMultiTouchTrackPadInstaller.exe"
    – Andrew
    Oct 27, 2012 at 9:22

Got my Apple Macbook Multitouch Trackpad drivers to install on 64 bit Windows 8 RTM.

Upgraded Windows 7 to Windows 8, keeping applications and files. As as result, Boot Camp 3.2 was already installed, but trackpad was not working.

Installing drivers manually using device manager from the Boot Camp 4 installation files failed. Windows compatibility mode failed. Hacking the BootCamp64.msi file using Orca to detect a different Windows version also failed.

So I went back to device manager which did not have any devices with problems, and I couldn't find the devices Apple Trackpad or Multitouch Trackpad. I tracked down two generic device entries called usb input device and figured out they were the trackpad installed with generic Microsoft drivers. When I tried to update these generic device drivers to the apple drivers, I got the error "system cannot find the path specified". Open up the system's SetupAPI log file and discovered the file not found error was caused by attempting to find driver files in DriverStore which did not exist:

C:\Windows\System32\DriverStore\FileRepository\applemtm64.inf_amd64_e9ad032101401c02 C:\Windows\System32\DriverStore\FileRepository\applemtp64.inf_amd64_e01424b60295b8a0

So I created those two folders and copied all of the *mtp64 and *mtm64 files from boot camp 4 installation files to these respective folders, and also copy the WdfCoInstaller01005.dll file into both folders.

After doing that I was able to use the device manager and install the apple trackpad drivers without any problems just by searching for the driver normally, and now my right click and two finger scrolling work great!


I have just upgraded Win7 to Win8 RTM on my Macbook Air 2011 (core i7, Bootcamp 4.0). I tried to install Trackpad++ but it failed, the latest drivers from Apple failed to install. But the solution here http://maxcho.com/2012/08/windows-8-on-a-macbook-pro/ worked perfectly.


I was only able to get the 32-bit install of Windows 8 RTM to work. The one annoying driver that remained was the Light Sensor (the display was always too dim for my liking). I didn't like only having 4GB RAM available, so I am switching back to Windows 7 (64 bit) until Apple gets the issue resolved.

If you don't need the track pad, you can always use the mouse.

  • You can uninstall the Light Sensor driver but the OS will install it again.
    – Mike
    Aug 23, 2012 at 1:41
  • You can disable automatic dimming by going to Power Options > Change Plan Settings > Change advanced power settings, expand Display, then Enable adaptive brightness and set one or both options to Off.
    – Paperjam
    Sep 30, 2012 at 20:41

Try Refreshing the PC, then running the Boot Camp setup.exe file... instructions and the download (which is otherwise a hassle to find) are here: http://lift.co/compapps/apple/win8/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .