Several Macs are able to connect to a printer on a Windows 7 machine, but there is one Mac that I can't get to hooked up.

When I go to add a printer, I can browse to our domain, but no computers are listed in the domain. Other Mac's list all the shared printers in the domain. This the only Mac with the problem.

This Mac will show devices in the workgroup, just not the devices in the domain. Again, it sees the domain, just not the devices in it.

I look at the suggestions listed here: Trouble browsing Windows network printers from Mac

But these did not work for me. I tried manually entering the printer using the username and password and it does authenticate.

I compared the network settings to a working Mac and they were both the same.

After adding a printer manually using a username and password, and trying to print a test page, I get the message On Hold - Authentication Required, and I cannot figure out how to then authenticate by entering a username and password again, in the event that were the problem.

  • Do the printer work if connected to the "problem" Mac?
    – Hoshts
    Aug 17, 2012 at 18:27
  • I have not tried that. I could try and let you know.
    – Dave
    Aug 17, 2012 at 18:35
  • 1
    Sounds like it's not binding/authenticating to Active Directory properly.
    – Harv
    Aug 17, 2012 at 19:09
  • Harv, I did some more searching and found that under Settings->Accounts is an option for authenticating to Active Directory. I still do not see the printers listed, but manually entering the printer now works. So you're right. If you want to make this an answer I'll accept. Thanks!
    – Dave
    Aug 17, 2012 at 23:00


You must log in to answer this question.

Browse other questions tagged .