I'm trying to get Xquartz to work in Mountain Lion, but when I click it, it starts up, then crash, then starts up again etc. It loops like this until I reboot or logout.

My console says this for every loop:

    8/15/12 10:00:21.806 PM org.macosforge.xquartz.startx[14953]: lockfile: Sorry, giving up on "/var/folders/vr/6swz_qtn60q0ld9lp_pbdqk80000gn/T//font_cache.lock"
8/15/12 10:00:21.806 PM org.macosforge.xquartz.startx[14953]: font_cache is already running.
8/15/12 10:00:21.806 PM org.macosforge.xquartz.startx[14953]: If you believe this to be erroneous, please remove /var/folders/vr/6swz_qtn60q0ld9lp_pbdqk80000gn/T//font_cache.lock.
8/15/12 10:00:21.830 PM org.macosforge.xquartz.privileged_startx[14842]: lockfile: Sorry, giving up on "/opt/X11/var/run/font_cache.lock"
8/15/12 10:00:21.831 PM org.macosforge.xquartz.privileged_startx[14842]: font_cache is already running.
8/15/12 10:00:21.831 PM org.macosforge.xquartz.privileged_startx[14842]: If you believe this to be erroneous, please remove /opt/X11/var/run/font_cache.lock.
8/15/12 10:00:21.893 PM org.macosforge.xquartz.startx[14953]: xauth:  file /Users/gav/.serverauth.14954 does not exist
8/15/12 10:00:21.953 PM org.macosforge.xquartz.X11.stub[14994]: Xquartz: Unable to locate waiting server: org.macosforge.xquartz.X11
8/15/12 10:00:21.956 PM org.macosforge.xquartz.X11.stub[14995]: Xquartz: Starting X server: /Applications/Utilities/XQuartz.app/Contents/MacOS/X11 --listenonly
8/15/12 10:00:22.305 PM SIMBL Agent[11494]: warning: failed to get scripting definition from /Applications/Utilities/XQuartz.app; it may not be scriptable.
8/15/12 10:00:22.306 PM SIMBL Agent[11494]: eventDidFail:'tvea' error:Error Domain=NSOSStatusErrorDomain Code=-600 "The operation couldn’t be completed. (OSStatus error -600.)" (procNotFound: no eligible process with specified descriptor) UserInfo=0x4001afc60 {ErrorNumber=-600} userInfo:{
    ErrorNumber = -600;
8/15/12 10:00:22.307 PM SIMBL Agent[11494]: eventDidFail:'tvea' error:Error Domain=NSOSStatusErrorDomain Code=-1701 "The operation couldn’t be completed. (OSStatus error -1701.)" (errAEDescNotFound) UserInfo=0x4001d7200 {ErrorNumber=-1701} userInfo:{
    ErrorNumber = -1701;
8/15/12 10:00:23.956 PM org.macosforge.xquartz.startx[14953]: /opt/X11/bin/xinit: XFree86_VT property unexpectedly has 0 items instead of 1
8/15/12 10:00:24.064 PM org.macosforge.xquartz.startx[14953]: /opt/X11/bin/xinit: connection to X server lost
8/15/12 10:00:24.065 PM org.macosforge.xquartz.startx[14953]: 
8/15/12 10:00:25.066 PM org.macosforge.xquartz.startx[14953]: waiting for X server to shut down 
8/15/12 10:00:25.113 PM org.macosforge.xquartz.startx[14953]: waiting for X server to shut down 
8/15/12 10:00:25.114 PM com.apple.launchd.peruser.501[129]: (org.macosforge.xquartz.startx) Throttling respawn: Will start in 7 seconds

I don't know anything about Xquartz, so I'm not sure how to diagnose the problem.

I'm using Xquartz 2.7.2 found here http://xquartz.macosforge.org/landing/

4 Answers 4


I was able to solve this issue on Mountain Lion 10.8.2 with XQuartz 2.7.4 by moving ~/.xinitrc.d out of the way (same effect as deleting it).

  • 1
    Similar issue -- I had an ~/.xinitrc file. Once I deleted it the problem went away.
    – bonh
    May 25, 2017 at 2:53

I too have experienced this. I will add that I did migrate over preference files, so possibly that has contributed to the problem. If I find the answer, I'll be back to share. Any luck on your end?

Possible solution... I'm sure this is not the best solution out there, but I'm here to mention what I experienced... after port uninstall X, I was able to get Xquartz to launch without the infinite loop. I also tried uninstalling xorg since I felt that should be installed via Xquartz (I could be wrong). With only X uninstalled, Quartz launched and I got what I expected to get for a Xterm window. With xorg uninstalled, I am getting no xwindow launch when called via the terminal, so I think I'm only halfway to an answer here. [or leave xorg installed and remove X] I will mention that my windows had no window handle, which was extremely frustrating, so I don't think this is completely solved yet.


Ok- I seem to have fixed mine somehow. I think it was a problem with all my initialization .files - watching the console, I was able to determine that there were lines from an older Fink install that were upsetting the start of the Xquartz server. In particular it may have been the source /sw/bin/init.sh line that was the primary problem. Be sure that all your rc files etc., are setup right and not missing things (check console to be sure) - .bash_profile, .bashrc, .xinitrc all had issues due to past installs for me. I hope this helps!

  • Thanks for the tip! I've had this problem forever, but I fixed by removing .xinitrc. I guess at some point, kde (installed through fink) had added something there to make X11 use the kde desktop, which was causing the problem.
    – asmeurer
    Sep 22, 2012 at 23:22

I too have this problem with Xquartz launching, quitting, relaunching. OS X 10.14.6 Mojave. Deleting .xinitrc fixed this for me.

  • Welcome to Ask Different and thank you for your answer. :) Unfortunately, short answers such as this don't really provide enough detail or context to help many users. If possible, it'd be good if you could add some more info on how you deleted .xinitrc. Also, you may want to read How to Answer for tips on providing answers here.
    – Monomeeth
    Oct 31, 2019 at 4:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .