The App Store on Mountain Lion pushes update notifications through Notification Center. Unfortunately, this also happens for users that are not system administrators (and so cannot run the App Store). How can I turn this off?

Notification Center has preferences, where applications can be vetted, but App Store does not appear in this list.

  • Isn't there an option in the System Preferences -> Notifications to disable App Store ?
    – Hoshts
    Aug 16, 2012 at 7:47
  • 4
    App Store does not appear in the list of applications there.
    – Thilo
    Aug 16, 2012 at 7:53
  • Bugger. Sorry for that. At work so couldn't look it up.
    – Hoshts
    Aug 16, 2012 at 7:54
  • 4
    Extra ugliness: You cannot dismiss the notification at all without bringing up App Store (which non-admin users cannot even use), and it also does not appear to fade away after some time either.
    – Thilo
    Oct 30, 2012 at 5:09
  • You may find you can drag the notification to the right to temporarily dismiss it without bringing up App Store, but it pops back up ~ half an hour later ... May 11, 2014 at 21:11

13 Answers 13


You can now simply go to System Preferences > App Store, and turn off "Automatically check for updates."

No messing with firewalls, and just works with App Store. So just remember to check every now and then manually to find out when you have updates!

  • 5
    This does not work on 10.8, can anyone confirm if this works on 10.8.1 or 10.8.2?
    – nylund
    Feb 5, 2013 at 9:05

I just discovered the missing solution here: http://osxdaily.com/2012/11/15/stop-software-update-mac-os-x/

You can selectively disable notifications about specific software updates you don't care about (like useless App updates) by control-clicking the update inside the App Store to reveal a hidden "Hide Update" option.

This is best for those who want to keep Notification Center active for all its other uses (calendar alarms, etc.) and who also want to be notified about critical software updates. It should permanently mute notifications about certain software updates (until that software comes out with a new update).

(Hopefully this also works for the case where non-admin users are getting update notifications they can't act on.)

Screen-capture from OSxdaily article:

enter image description here

  • 2
    It's fine to copy / screen-capture directly from a source, in fact preferable to using a link, because in the long run, a great many links get deleted, or changed.
    – gosmond
    Feb 23, 2013 at 7:17
  • Can users who are not an administrator (and cannot run the App Store) get to the App Store to click the "Hide Update" button?
    – D.W.
    Feb 23, 2013 at 7:32
  • 2
    This works for individual system updates (under the "Software Update" group), but the menu doesn't appear at all for other apps in the list. :(
    – jmk
    Sep 27, 2013 at 18:03
  • @jmk id right. doesn't work with apps. :(
    – skywinder
    Feb 5, 2015 at 13:31

The best solution I've found for this so far has been to +'click' the notifications menu icon in the top right and disable notifications. This resets every day though.

  • Where the heck did you get that from? (not saying the answers wrong, just Apple just have not implemented anything to do with the Mac App Store well at all)
    – Jonathan.
    Dec 30, 2012 at 14:10
  • 1
    This disables all notifications, not just the Mac App Store ones.
    – TJ Luoma
    May 16, 2013 at 14:19

I found that the preferences for the notification center are located in a sqlite database in ~/Library/Application Support/NotificationCenter/ The file is named with a GUID so I'm not sure if it's the same for every account, but it was the only file in the directory and has a .db extension. I used the following sql command

update app_info set flags = 134 where bundleid = 'com.apple.appstore'

I'm not 100% sure if it is working or not, but you can try it by running

sqlite3 ~/Library/Application\ Support/NotificationCenter/*.db "update app_info set flags = 134 where bundleid = 'com.apple.appstore'"

in a terminal.

Meaning of Flags

As suggested, here's what I was able to figure out about the flags value by modifying entries through System Preferences and observing the resulting change in flag value.

The flag value appears to be a bitmask of at least 16 bits as follows

|   |   |   |   |   |   |   |   |   | M |   | A | b | S | B | H |

The meanings of the fields are

M Set if the options have been modified from the default values
A Set if alerts should be shown for the application
b Set if banners should be shown for the application
S Set if "Play sound when receiving notifications" is checked
B Set if "Badge app icon" is checked
H Set if "Show in Notification Center" is unchecked

I was not able to find any meaning for the remaining fields. The value 134 is the original value that the appstore entry had (which was 150) but with the alert bit cleared. I thought one of the extra bits set on the appstore entry was the one that caused it to be hidden from the preference pane, but even after clearing them it did not show up.

  • Do you have any documentation about this database, especially about the meaning of different values for the flags attribute? I would be rather reluctant to run this without a reference.
    – nohillside
    Mar 29, 2013 at 15:40
  • 2
    @patrix Unfortunately there's no documentation, I just observed how the flags changed when I modified the alert style for other items and applied those changes to the entry for the appstore. I'll add some info on what I deduced to the answer. Mar 29, 2013 at 16:12
  • The flags for the App Store are reset all the time (modifying them while not logged into the GUI didn't help), so this doesn't work
    – Tobias
    Dec 4, 2013 at 9:59
  • @Tobias pity! Seemed like a cool hack otherwise. I wonder which app resets the flags, and if it's hardcoded... What would happen if you delete com.apple.appstore altogether?
    – cavalcade
    Dec 14, 2013 at 5:17

I recently discovered that you can dismiss individual notifications by clicking on the app store update notification, and swiping/dragging to the right. I do it about 20x a day because I don't have the time to restart my iMac every day for software updates.

  • 2
    Also, on a Magic Mouse (and presumably a trackpad), you can swipe on the top without clicking to right for this same behavior.
    – Ethan Lee
    Nov 16, 2012 at 0:30
  • 2
    +1. This is what I do now. And yes, I do it about 20x a day because it keeps coming back all the time.
    – Thilo
    Nov 22, 2012 at 1:42
  • What mac do you have that requires daily restart for updates? 99.999999% of my updates don't require restart lol
    – Alexander
    Feb 1, 2014 at 3:03
  • The swipe gesture is like a 5 minute snooze i believe
    – Alexander
    Feb 1, 2014 at 3:04

Disabling App Store Notification

Open your Applications folder and navigate to the App Store application. Right click on the application and select ‘Show Package Contents’. Select the contents folder. Within this folder you will see an application named ‘Info.plist’. Copy this to the desktop or another folder. Open this file in Text Edit. There are various options within this file. Scroll down to the option which states. NSUserNotificationAlertStyle 
alert Change ‘alert’ to ‘none’.

Save the file and copy it back to the location in which you found it. You will have to authenticate with your admin password to make the change since you are altering a protected system file. You may need to restart the App Store application, or your Mac. Credit for this idea is found on imgur.

  • On 10.9.2 it shows <key>NSUserNotificationAlertStyle</key>
    – Ruskes
    Apr 9, 2014 at 10:16
  • or change 'alert' to 'banner' if you still want the notification to pop up, but you want it to be dismissable without opening the App Store like normal notifications.
    – honi
    Dec 19, 2014 at 17:15
  • In case anyone runs into problems with this approach, I had to disable System Integrity Protection (SIP) on Catalina (boot into recovery mode w Command +R, authenticate, open terminal "csrutil disable" reboot, and mount the root directory "sudo mount -uw /". I believe this would be necessary on Mojave as well. I used root account to overwrite the info.plist on the terminal, not sure if using root was necessary but it worked for me. If you have not enabled root, the terminal command is: "Dsenableroot" and to disable root the command is "dsenableroot -d".
    – adamlogan
    Jul 2, 2020 at 1:16
  • When you're done with all this, it's advisable to re-enable SIP by booting into recovery mode again, authenticate, open Terminal and enter "csrutil enable".
    – adamlogan
    Jul 2, 2020 at 1:17
  • Implementing this solution has resulted in an undesirable outcome for me. I can no longer open the App Store (it crashes on launch). Crashing was experienced by replacing "alert" with "none" or "banner". However, apps appear to continue to update in the background, and notifications continue to appear, so this solution gives no benefit. I would not recommend this approach for Catalina users and perhaps Mountain Lion users as well. I was able to reverse the operation and get the App store functioning normally again by changing the string from "none" or "banner" back to the default "alert".
    – adamlogan
    Jul 15, 2020 at 3:54

It's located in:

System Preferences < Security and Privacy < Firewall < Firewall Options (you might have to activate this) < + < AppStore

Click the arrow on the right for a drop down to select "block all incoming connections" and I keep it like this until I decide it's time to update everything.

  • 2
    This will block automatic updates entirely, not just hide the notification. Administrators should definitely not use this option, although it might be OK for OP.
    – Quantum7
    Nov 22, 2012 at 18:14
  • It's extreme, but it stops a bunch of problems (Apple sometimes spams your internet connection - I've had periods where Apple re-checks this state every 30 seconds, causing problems when you're trying to use your machine for anything CPU+b/w intensive (e.g. distributed builds).
    – Adam
    Dec 2, 2012 at 19:12

Uh....for some reason I can't respond to Buscar up there who is talking about the whole <key>NSUserNotificationAlertStyle</key> thing, in response to "App Store Is Annoying".

If you go to info.plist in the package contents, and it looks all XML-y, I think the trick to this is to find that line with NSUserNotificationAlertStyle inside the <key> tag, and then look below for the <string> tag, which should be sandwiching the word "alert". Just change "alert" to "none"... I think that'll work. Will restart & test out now.


Update: This doesn't work, the key appears to be ignored for some reason.

I think you might be able to change the default behavior of App Store.app by changing the NSUserNotificationAlertStyle plist entry from alert to banner. I just applied this change myself, but haven't been able to verify that it works because there haven't been any updates yet.

Here's what I did:

sudo nano /Applications/App\ Store.app/Contents/Info.plist

Find alert: ^w alert<

replace with banner and save ^x y

  • 2
    You should be able to delete your own answers if they are invalid.
    – nohillside
    Feb 5, 2013 at 21:29

If you wish to go one step further and disable Notification Center permanently, open the Terminal (located in Applications/Utilities), and type in the following command followed by the return key:

sudo defaults write /System/Library/LaunchAgents/com.apple.notificationcenterui KeepAlive -bool false

You’ll be required to type in your administrator password to continue with the request to disable Notification Center. You can re-enable notification center by replacing “false” in the above statement with “true.”

After doing that, type in the following command to quit the Notification Center:

killall NotificationCenter When you log out and back in to your Mac, the Notification Center icon in the menu bar will be missing.


You can simply hide the update in the Mac APP Store or wherever your notification is coming from.

Acknowledgements : http://www.maclife.com/article/howtos/how_disable_notification_center_mountain_lion


Try: System Preferences, App Store, and turn Automatic Updates off. Simple

  • Although the question could be more specific about the need. Your answer is incorrect. There is no "Turn Automatic Updates off".
    – markhunte
    Feb 9, 2014 at 18:59
  • Maybe not on your machine way back then, but for the record I see it on MacOS Catalina as of 7/1/2020. Open App Store App > (in Menu Bar) App Store > Preferences > [check box] Automatic Updates.
    – adamlogan
    Jul 1, 2020 at 23:54

Open System Preferences > Software Updates, then uncheck the box that says "You will be notified when updates are ready to be installed".


Go to setting>notification>app store>disable allow notification

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .