2

Device : iPod Shuffle 2nd Second Generation OS : Windows 7 64 bit

My steps were as follows

enter image description here

I checked the "Sync only checked songs"

enter image description here

Even though i checked some songs before syncing, i did not find any of them in my iPod. The sync completed without any error output.

Settings tab

enter image description here

Contents tab

enter image description here

3
+100

There is an Autofill button that you must select (click) before syncing to get the music onto the device.

1

Get info for the checked tracks and see if in the Options tab, Skip when Shuffling is checked. If so, those tracks won't sync to an iPod shuffle.

-1

As someone's said, the square button that says 'automatically fill space with songs' has to be ticked. I spent two hours trying to work out what was going wrong before finding this answer on here. The labelling of the button is misleading - iTunes only puts the songs you have ticked on your device, it doesn't randomly fill the whole thing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .