On Mountain Lion, I've got Gatekeeper enabled and set to allow Mac App Store apps only. Now: if I download any app from the internet (and I'm talking about apps I've never run before) it just runs, Gatekeeper seems to be not working at all. Does anybody know what's happening?

  • Maybe it's allowing the apps because they're registered as having a Developer account? Surely it should still not run them? Odd.
    – hellothere
    Aug 15, 2012 at 10:07

2 Answers 2


As bogdansrc mentioned, Gatekeeper only applies to application bundles that have a com.apple.quarantine extended attribute. Some applications (like μTorrent) don't add them to the files they download, and some unarchiving programs (like unzip) don't add them to files after extracting archives.

You can list extended attributes with xattr -l.

Gatekeeper is also disabled if you have disabled LSQuarantine with for example defaults write com.apple.LaunchServices LSQuarantine -bool false.


It should not run them. However, what browser are you using? Can you replicate this if you download the app with Safari?

In order for GateKeeper to work, the browser you downloaded the app with needs to set a "internet downloaded" flag on the file. This way, GateKeeper knows that you have downloaded the app from the Internet.

P.S. This should give you an idea on how "secure" GateKeeper is.

  • I used Safari to download those apps, and two of them are not signed (as their developers say on those apps' websites)
    – user732274
    Aug 15, 2012 at 11:37
  • Did you download/run them before setting GateKeeper to "App Store only"? If yes, they're already allowed on your Mac and the current GateKeeper setting doesn't matter.
    – bogdansrc
    Aug 15, 2012 at 12:50
  • No, I ran them AFTER setting Gatekeeper.
    – user732274
    Aug 15, 2012 at 14:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .