1

I have both Oracle Java 7 and Apple Java 6 installed. Apple Java 6 is disabled in Java Preferences.

Now, when I try to launch Java Preferences I get a "Cannot launch "Java Preferences - No compatible version of Java 1.5+ is available." error:

Java Preferences error

This is the output of /usr/libexec/java_home -V:

Matching Java Virtual Machines (1):
    1.7.0_05, x86_64:   "Java SE 7" /Library/Java/JavaVirtualMachines/1.7.0.jdk/Contents/Home

/Library/Java/JavaVirtualMachines/1.7.0.jdk/Contents/Home

Besides the (Oracle) 1.7.0.jdk folder, /System/Library/Java also contains a 1.6.0_31-b04-413.jdk folder.

  • With more recent distributions of Java from Apple and Oracle, the question is no longer applicable; an update from Apple explicitly removes Java Preferences from the Utilities folder. – Graham Perrin May 26 '13 at 5:37
2

Java for OS X 2012-004 isn’t available any longer. But 2012-005 solved the issue for me.

1

You need to install Apple's Java package. Currently, the latest version is 2013-001

0

I've solved it by installing Java for OS X 2012-004 from Apple.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .