I have connected an external drive to my Airport Extreme, but it doesn't show up in Finder, and it doesn't show up in the list of drives when I connect to the Airport Utility.

The same drive worked previously, but I have since reformatted it. The drive works fine when connected directly to my Mac via USB cable.

Update I don't recall how the drive was previously formatted, except that I had both a Mac and Windows partition, and the Airport Extreme recognised both of them. Now I've formatted it as a single partition, with format: Mac OS Extended (Case-sensitive, Journaled, Encrypted)

  • 2
    What format is the drive in?
    – de_an777
    Commented Aug 13, 2012 at 22:51
  • 1
    Is the current format the same as when the drive worked properly (HFS, NTFS, etc.)?
    – JW8
    Commented Aug 13, 2012 at 23:12
  • Sorry for slow response. I've answered as an edit to the original question.
    – Peter Hall
    Commented Aug 22, 2012 at 20:12
  • I'm having the same problem. What model of USB drive are you using? Commented Oct 28, 2012 at 20:50

6 Answers 6


I had the same problem with my Western Digital USB drive. I re-formatted it as Mac OS Extended (Journaled, not case-sensitive, not encrypted) and it worked.

  • I tried, but it didn't help reformatting the disk to case-insensitive.
    – gregers
    Commented May 10, 2016 at 20:02

I would probably reformat the drive as journaled HFS+ but not Case Sensitive. Encryption is fine, but Case Sensitive is a pain in the arse, especially because the OS X is generally not case specific.

You plugged the USB drive into the AirPort Extreme, but did you use the AirPort Utility to configure everything to work together?

The rightmost tab/button is where you configure attached storage. You'll need to set the password security for either plain visibility when you useFinder to log into the AirPort Extreme, or if the hard drive will require its own password, independent of the device password.

Whole the setup parameters are fairly straight-forward, I may have missed one or two checkboxes. I'm doing this from memory.

Good luck!


Given the same drive worked previously, I think the format is most likely to be the issue, as covered in other answers here. However, I have come across the "drive doesn't show in AirPort Utility or anywhere else" issue with my AirPort Extreme 802.11n (2nd Generation) (purchased 2007) a few times and thought I'd share what I'd found:

  1. This AirPort Extreme model doesn't provide a lot of power to the USB port. Some drives spun up, and the power light on the drive lit up, but the drive didn't show up in the AirPort Utility. I fixed this issue by providing power to the drive via a split USB cable and mains USB power supply.

  2. For one particular drive, I found the controller board in the drive enclosure was incompatible with the AirPort Extreme. The drive didn't show up in AirPort Utility. When I moved the drive into a different enclosure, it all worked OK.


I ran into the exact same issue with a 1 TB Western Digital disk. It turned out that the disk was encrypted using the WD security app. Once I turned this feature off, the drive showed up in Finder (via "Export Extreme" under the "shared" category).


I had the same issue with an USB 3.0 drive. It was formatted with HFS+ and had external power, but still wouldn't work. The problem was that I used the USB 3.0 cable that came with the drive. When switching to an old USB 2.0 cable and rebooted the AirPort Extreme it finally showed up in AirPort Utility.


I have the same issue with encrypted Toshiba external drive. Once I removed the encryption on one of the two partitions, both appeared via AirPort Extreme.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .