I have a Netgear Wireless Modem Router which I have configured to not broadcast it's SSID and the security level is set to WPA2 with a MAC Adress Filter. When I manually connect to the wireless network through the Wireless settings then my Mac has a hard time to even find the network and just gives the message that the timeout was to long. When I manage to connect with the wireless network then my Mac will hold the wireless connection for sometime until some random time the mac will disconnect itself from the wireless Network and then I will have to repeat the same procedure with reaching the wireless Network.

Does Anyone know what is causing these troubles?


1 Answer 1


Could be one of many, many things. Have you tried altering the security settings on the router? Are you close to the router? Strong signal strength?

Have you tried connecting other laptops? Is the behaviour different?

Try opening your console (/Applications/Utilities/Console) and connecting. Show the log list and switch to the system log. Watch it, connect to your wireless network, and wait for it to disconnect. Look through the log from the time you connected to the time it disconnected, and see if there are any messages which might indicate what's going on.

Your question is not specific enough, yet, for a proper answer. Give us more to go on.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .