21

I want to set the "Homebrew" theme to be the default in Terminal. I've changed the setting in the preferences: I chose "on startup, open" : "new window with settings" : "Homebrew".

Here is a screenshot: screenshot of Terminal's "startup" preference pane

Terminal uses "Homebrew" only for the first window. Then I do cmd-W to close the window and cmd-N to get a new window. The new window appears with the "Basic" theme! But if I do cmd-Q and restart Terminal then it gives me a "Homebrew" window again. Why don't terminal themes work properly?

  • “On startup” means “when starting Terminal”, not “when opening a new window”. – Chris Page Aug 15 '12 at 3:42
42

Go to Terminal → Preferences → Settings → Profiles, select the Homebrew theme, and click the ‘Default’ button. Then quit Terminal and restart to confirm it works.

  • 1
    thanks, that really helps! Anyway, the app's behavior seems to be wrong, I have an option "New window opens" set to "Same profile", not the "Default profile" and it opens the default, not the same. It's not clear why do they have same/default option, if both actually default? – user109884 Jan 16 '15 at 8:35
  • Hi, what if the default button is greyed out? Any guesses why it might be so? If it's a matter of my privileges (this is a work computer) I will scream. – pgblu Dec 31 '15 at 13:05
  • oddly enough this works. But not with the "solid colors" theme. The latter changes colors on each new launch o.O – Ufos Nov 2 '16 at 20:56
2

On High Sierra, Terminal, Preferences, General then New window, select profile and

bottom half:

New window opens with Same

New tab open with same

  • 1
    This doesn't seem to be enough for me; almost every other time or so, I launch the app and it starts with the default "Basic" profile, and I need to restart the app so that my chosen profile is used. I think it's a bug on Apple's part... – Nicolas Miari May 17 '18 at 4:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .