Unfortunately I used a bad VPN service called VPN OneClick Pro. When you uninstall the app it does not remove the VPN configuration files it creates in Network in System Preferences.

So in other words, when you open System Preferences and then click on Network, to your left you always see your Wi-Fi, Ethernet, Firewire, etc. VPN OneClick Pro places about 28 VPN Configuration files. The minus button "-" has been greyed out so removing them is impossible.

How do I remove the remnants ?

  • Do you have the System Preferences unlocked? Open System Preferences, choose Network and there is a padlock icon at the bottom left corner. If it is locked, click on it and it will ask you for the admin password, after unlocking you should be able to delete these entries. If already unlocked -- I am not sure what the problem may be.
    – lupincho
    Aug 11, 2012 at 7:05
  • Thanks for the reply, yes it's already unlocked but the "-" button is still greyed out.
    – Roland
    Aug 11, 2012 at 19:16
  • The VPN settings are in /Library/Preferences/SystemConfiguration/preferences.plist under NetworkServices, check what User Defined Name says to find these entries. If you have plist editor installed (e.g. via Xcode) you can edit that file (create backup first) and delete these entries. If you don't have plist editor, you should be able to edit the .plist file using a text editor, HOWEVER I WOULD STRONGLY RECOMMEND AGAINST DOING SO because it is very very easy to mess things up and render the system nonoperational.
    – lupincho
    Aug 11, 2012 at 20:30

10 Answers 10


To remove the VPN Profile from your Mac:

System Preference > Profile > Vpn One Click > Remove.

  • "Profiles" rather than "Profile", but this is the right answer Jul 2, 2020 at 16:12

If you can't remove vpn in the System Preference, you can remove it like this:

open Terminal.app, run the command below to get vpn name

networksetup -listallnetworkservices

then run the command below to remove it

networksetup -removenetworkservice "vpnname"

The problem appears when you first uninstall VPN and then try to remove the configuration from Network Preferences. So next time first go to Network preferences.

If that's too late this way is dummy-proof, worked even for me:

In /Library/Preferences/SystemConfiguration, track down the following 3 files:


Have no fear, remove these files and restart your Mac.

All network configuration will be deleted and your Mac will have the default settings again. So take note before you begin, but the actions are simple enough even for me.

VPN, Bluetooth PAN, and Thunderbolt (bridge) connections will probably all be lost. You will have to log into your Wi-Fi again so have your password handy.


I ended up with an MDM-installed Algo VPN IKEv2 IPsec profile that Network Manager cannot delete.
The deletion sign is greyed out:

Grayed-out Delete Profile Button in Network Manager

Typically, one would uninstall the corresponding MDM Profile to remove the linked VPN Profile, but I had no MDM Profile to delete.

Reinstalling the original .mobileconfig MDM profile would create another VPN Profile, and removing MDM Profile would only delete a second VPN Profile, leaving the original one intact.

I found that such VPN profiles are stored in the /Library/Preferences/com.apple.networkextension.plist binary plist file.

I already had PLIST Editor, so I used to remove $objects array elements mentioning stale VPN profile.
Since this is a system plist, one would need first to copy it somewhere to edit and then copy it back with the modifications.

  • Same Issue, but pigletfly's answer did it. Note that disabled networks may show up with a preceding Asterisk ( *AlgoVPN algo ) but networksetup -removenetworkservice "AlgoVPN algo" worked for me. Aug 25, 2021 at 17:23

You can remove them from the place you have the original file.

I had the same problem on my iPhone. It has a red button that said "Remove".

  • 2
    Perhaps you could expand a little more on your answer. Do you have a file path you could provide or could you elaborate on how the iPhone issue pertains to the OP's problem?
    – jbharper2
    Dec 16, 2012 at 11:20

Open the finder, press Cmd + shift + G and paste this: /Library/Preferences/SystemConfiguration/preferences.plist copy the preferences.plist file to your desktop (Admin account) right click and open with X-Code (Get it if you don't have it, it's free) Expand the NetworkServices key, expand every group in that key and look for the UserDefinedName you need to delete (VpnOneClick - something) click the - button to the right of the group number (make sure the that row is selected) you will notice the whole group is marked in a blue square when that is done. Save the file Drag the file on the desktop to the original location and authenticate Open the network settings and you will see the vpnOneClick entries are gone!


system preferences profile Vpn One click and then the '-' button you have in network settings to, it worked with me flawlessly


First of all go to System Preferences, then Network, then click on VPN on the left. Click click on the minus button under the screen and remove all the VPNs, then close it.

Now go to Finder → Applications and delete VPN One Click

If the system says VPN One Click is running, then quit the app from the Dock and try again.


I had the same issue with IPVanish. They installed probably 30 or 40 different VPN configurations, and going through each one and selecting Remove would be aggravating and tedious. I just deleted the file: ~/Library/Preferences/ByHost/com.apple.networkConnect.<UUID>.plist. It's a binary XML, so open it in Xcode or TextMate first to confirm that there's nothing there which is important to you. Or rename the file and/or set permissions to 000. By the way, this is on macOS Sierra. So other OSX versions may differ.


System Preference > Profile > Vpn One Click > Remove.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .