1. I upgraded from 10.7 to 10.8 on 7/28/12
  2. I upgraded Xcode from 4.4 to 4.4.1 on 8/8/12


  • On 8/9/12, on my MacBook Air, Mail.app refuses to connect to the SMTP service on a server that I frequently use. Mail.app reliably connects to the IMAP and WWW services running on the exact same server. Mail.app also reliably connects to 4 or 5 other SMTP servers.


  1. Incoming Mail is set to use IMAP on 993 with SSL. No problems with incoming mail.
  2. Outgoing Mail is set to use the default ports, with SSL and Password authentication.


  1. I can telnet to the server on port 587 with no issue. The server responds as it should.
  2. I can ping the server and connect to it via SSH or WWW.
  3. My iPhone and iPad with the exact same SMTP settings are able to, from the same WiFi network, send mail without issue.
  4. The same problem happens if I use the server's public IP or its domain.
  5. I experience this on my network at work and when connected through a VPN to another network.
  6. I have deleted and recreated the SMTP server in Mail.app with no success.
  7. I have deleted and reinstalled the certificates associated with the server with no success.
  8. I tried to create a new IMAP and SMTP account for the same server using another name and password. Upon setup, IMAP was found and connected immediately, but the SMTP server was never found.
  9. Using Sparrow, I tried to add an account on the server and also did not get past the SMTP portion.
  10. Connection doctor shows NOTHING as far as attempts to reach the server for SMTP. All IMAP attempts are logged and attempts to reach the other SMTP servers appear as they should. But, there is nothing showing for attempts to reach the SMTP service on the server in question.
  11. In my SMTP server settings, I tried manually adding 587 both with SSL and without without any success. My mail server only accepts on 587.
  12. Restarted Mail, restarted MacBook Air, flushed DNS entries.
  13. Dragged the Mail and Mail Downloads Folders out of ~/Library and tried recreating the account. Again, it connected to IMAP fine, but stalled when trying to connect to the SMTP server.
  • I had similar problem but with Thunderbird and SMTP on non-standard port. Similar symptoms, other SMTP servers would work fine, iPhone on the same wi-fi with the same settings would work; using VPN to avoid SMTP filtering by the ISP won't help, changing DNS servers and flushing them won't help. What helped was setting "use STARTLS" in the client.
    – lupincho
    Commented Aug 11, 2012 at 20:52
  • How did you enable use STARTLS in the client? I'm using Mail.app, but it sounds like you're using Thunderbird. Commented Sep 19, 2012 at 18:23
  • Yes, I am using Thunderbird, not sure how to do that or if it is even supported in Mail.app.
    – lupincho
    Commented Sep 19, 2012 at 18:57

1 Answer 1


I ended up having to go to ~/Library/MailData, edit Accounts.plist, and remove the keys and value entries related to SSLEnabled. Luckily I had a POP server that was okay to copy from. There were two entries, first the SSLEnabled one and the following entry all good for now.

  • This is interesting and smells like a potential fix. My gut said that it was related to some security issue with the migration from 10.7 to 10.8. Sadly, I gave up some time ago and just moved the hosting of my mail server from a box in my home to a dedicated hosting plan. Since I've done that, I haven't had any issues. Commented Sep 19, 2012 at 18:20
  • Also, now that I think about it, how does this explain why Sparrow wasn't able to connect? Would Sparrow being using totally separate settings? Perhaps this was just some issue with my Postfix mail server which, admittedly, had not been updated for some time 18+ months and 10.8. Commented Sep 19, 2012 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .