I installed Mountain Lion yesterday and find that when my 2 year old iMac comes back from sleep it finds the router and connection but fails to allow internet connection. In other words it indicates the machine is connected but I cannot access Mail or use any Internet browser.
I have two PCs in the house that have no problems, so I assume the problem is neither with the modem or the router. There was never a problem when I was running Lion, it began only after installing Mountain Lion, so once again I assume the problem is with the new operating system. My iMac is circa early 2010. My son's iMac (2012) is not demonstrating the same problem. The most reliable way to establish an internet connection is to reboot my router (NetGear N300). When the computer reconnects after the reboot, it invariably finds the Internet. I have occasionally been successful Turning Wi-Fi off, and then back on, but most times not. I see that other users are reporting similar difficulties. Even if no one has an answer I hope that this is brought to the attention of Apple Engineers and a fix is quickly forthcoming.


4 Answers 4


I tried all the tips imaginable. The only solution was to set the channel on the wireless router on channel 11. It seems to me, the Mountain Lion has a problem when the channel the router is in automatic, then every time the channel is changed, the connection of the Wi-Fi card of MacBook drops.


I had the same problem with my MacBook Air. Resetting its SMC (System Management Controller) seems to have worked, the problem hasn't surfaced since.

It seems worth trying this, instructions here

  • Great idea, great instructions, did not work on my iMac. The computer came back up and was unable to find the router address. However, I found that running "network diagnostics" fixes the problem without having to reboot the router. This is not a fix, but a work-around. Apple will have to address the real issue. Aug 12, 2012 at 14:43

I hope you've resolved the wifi issue with your iMac. My daughter's 2012 MacBook Air would not be able to keep a wireless Internet connection, even with the wireless router with clean line-of-sight in the same room. I know how frustrated she was (and I was, trying to help!) I remember how many times we would reboot the router to regain the connection.

It took a while, but I tracked the root of the issue to the new power-saving modes Intel and Apple have incorporated into their newer computers. In the distant past, a computer could not independently power down a complete subsystem, such as the wifi networking components. Power savings was more of an all-or-nothing practice: your computer was asleep or it was not.

Today, saving power is much more granular. Your computer can power down almost any subsystem, and often does without your even knowing! I don't have definitive proof, but I believe the newer Mac hardware will even power down the wifi subsystem while you are reading a web page... not just for longer periods of complete inactivity.

Older wifi routers would keep an "inactive" connection open for a shorter window of time before releasing the connection, because the computer would ping the router several times a second. Today's Macs will let the connection sleep for longer periods of time, thereby saving power. With this longer timeout period, the router would think the computer had turned off. Restarting the router would renew and reconnect all devices.

If you can find the device timeout in the N300's configuration, try setting it to a longer time duration before dropping a connection.

The full story is here: Wi-Fi connection randomly disconnects on 2012 MacBook Air


I had the same problem. I solved it by using a cable instead of wifi connection. All the others, iPad,xpria,etc work normally. I hope this can help you

  • Using a cable would be impractical since I have my router downstairs and my desktop upstairs. The problem is eliminated if I never allow the iMac hard drive to sleep, but this is hardly a fix. Apple will apparently how to address the issue. Aug 10, 2012 at 21:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .