I am trying to submit a podcast to iTunes for the first time, and thought everything was going well, but I just got a rejection email:

Dear podcast owner,

The podcast located at the URL shown below has been blocked or removed from the iTunes directory as a result of technical problems with the feed.

Name: In His Word Feed URL: http://joshburnett.org/podcast/rss_source.rss

If you wish to reactivate your podcast in the iTunes directory, please troubleshoot your feed and check the functionality of each episode. To test your podcast, start iTunes, select Subscribe to Podcast from the Advanced menu, and enter your feed URL in the dialog box. If you can successfully subscribe to your podcast and listen to each of the episodes, you can reactivate your podcast by resubmitting the feed using the Submit a Podcast page, https://phobos.apple.com/WebObjects/MZFinance.woa/wa/publishPodcast.

For more information on troubleshooting feed problems and controlling the appearance of your podcast on iTunes, please see the podcast FAQ at http://www.apple.com/itunes/podcasts/faq.html and technical specification at http://www.apple.com/itunes/podcasts/techspecs.html.


The iTunes Store Team

I tried the test submission through Advanced>Subscribe to Podcast. It takes a few seconds to load and then it is subscribed on my iTunes. I click "GET" and the podcast downloads. But then it won't play. When I double click it, it just downloads again (and keeps doing that). I'm not sure what I'm doing wrong. I've looked at other podcasts RSS files, and tried to make sure mine has everything I need. Any thoughts?

Here is the feed url

My directory looks like this:

  • root/
    • podcast/
      • audio/
        • podcast1.mp3
      • index.php
      • podcast1400.mp3
      • rss_source.rss

Update: I finally narrowed it down (I think). Everything seemed correct, but I finally tried a couple different MP3 files and submitted the podcast and it worked. So, I'm wondering if the audio file my client gave me has issues. When I go to "Get Info" for other MP3 files, it shows things like "Audio Channels", "Total Bit Rate", and stuff like that. The MP3 file I am using doesn't really show anything. All I know is it says it's "Kind: MP3 audio" and "64865838 bytes". Any thoughts? I know pretty much nothing about audio, I'm a web developer. I can provide the audio file if anyone wants to download it and check it out.

  • Could you post your mp3 file it sounds like its not coded well (no pun intended)
    – Akshat
    Aug 16, 2012 at 19:12
  • @Akshat "encoded". Aug 16, 2012 at 21:03
  • Not only posting your MP3, but what information on what/how you're recording and exporting it? Aug 16, 2012 at 21:03

1 Answer 1


Okay, after a long period of troubleshooting, I determined it was the MP3 file that was having issues. After importing it into GarageBand and exporting it from there, it finally worked! I received the MP3 file from the client. He is a preacher and they recorded it at the church. Then he uploaded it to Google Drive and I downloaded it from there. It sounds like it was not encoded correctly, but I am not an audio expert.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .